.deb packages open via zip file manager by default

This is quite annoying, especially for non-pro users who are unable to install software downloaded from the internet. I don’t remember this being the case with 19.04.

Is there a way to change this via a bash script, the default app to open certain extensions?
For .deb it should be Software… for .txt, .conf, .sh etc I want it to be Pluma.

Looking for a way to do it via bash script so I can do it for all devices easily.

User’s side, it’s stored in ~/.config/mimeapps.list

I also thought by default .deb packages were supposed to launch « software » but you are right, it’s archive-manager on UBudgie 20.04

You may restore that association by right-clicking on a .deb file, properties, « open with » tab.
There « software installer » is proposed as recommended.

1 Like

There are more little things like this… I hope they will be fixed via an update before 20.10.

Well we could argue about that : non-pro users should never install software downloaded from internet while using a Linux distribution. That’s what official repositories from such distributions are for.

Non pro-users in need of new software should use :
⋅ first, any dedicated app-store provided by their distribution ( software, discover… )
⋅ or, package manager such as synaptic, gnome-package-kit, muon…

Then when they become geek, they might look for :
⋅ ppa ( for Ubuntu and its derivatives )
⋅ things downloaded here and there over internet at their own risks.

I wouldn’t advice snap, flatpak, or AppImage for non-pro users, as they still require too much manual attentions for viable and comfortable settings.

( I use all of them and they don’t ease life - only advantage is version freshness ).

3 Likes

neat tip for mimeapps.list, thanks.

@zilexa what more than dpkg -i *.deb would you want in a bash script?

xD

another tip

sudo apt install ./*.deb

This will install the deb - together with any dependencies automatically

4 Likes

Or, perhaps dpkg followed by apt-get install -f to deal with any missing depends- this way one can avoid creating a local apt repo.

Well the first question remains open : why clicking on a .deb does not launch an installer by default ? Or a package manager, if installed ? Or the current app-store-thing ?

Is this intended to prevent people from manually installing .deb packages ?

( apt-get can be replaced by shorter apt ).

well its a bug. For some reason gnome-fileroller has hijacked the .deb mimetype. Why gnome-fileroller did that is a very good question.

2 Likes

Well… half a bug : a .deb is an archive so it may be opened with fileroller. The bug is why fileroller first, and installer only recommended as a secondary option.

well, following along the note from @Coeur-Noir adding the type manually totally does the trick, worked right away- just do a:
echo "application/x-debian-package=gnome-software-local-file.desktop;" >> ~/.config/mimeapps.list
:+1:

True true

The graphical way is to right click the deb in nemo, open in another app, choose gnome software and ensure you tick the option to make it the default.

1 Like

You may install gdebi first, then right click .deb package open with gdebi installer

Ok, at least it’s a common issue in Ubuntu, not Budgie specific → https://itsfoss.com/cant-install-deb-file-ubuntu/

1 Like

But will it be fixed in Budgie 20.04.1 next month?

Things dont get fixed unless someone raises a bug report against gnome-fileroller on launchpad

@Hellxz
No need to install anything new, right click any .deb —> “open in software installer” on Budgie works as distributed

@zilexa
Aside from a future update in fileroller, adding the mimetype explicitly corrects the default behavior (without needing to right click)

There is no such thing as gnome-fileroller https://packages.ubuntu.com/search?keywords=gnome-fileroller&searchon=names&suite=all&section=all

Here you are https://bugs.launchpad.net/ubuntu/+source/file-roller/+bug/1889317

( Guys, the idea is to mark yourself as affected on the report )

1 Like

You can just:

  • go to the deb file, right-click it and select properties
  • go to the open with tab
  • select software install in the list and press the set as default button.

Now it will always use that application on double-click, etc.

This is a drive-by post before my next meeting. Sorry if it is duplicated or I am missing something detailed above.

1 Like

Mmmm…

So duplicate / already reported.

Answer is it’s either :

  • fixed in desktop-file-utils
  • or to be fixed Budgie’s side.