OneOdio Pro-10G Mic not working

Hi all :slight_smile: ,

I recently bought the OneOdio Pro-10G headset.

As you can see from the screenshot below, the output (headphones) device is working properly, while the input (microphone) device is not being recognized and it fallbacks to the Internal (PC) microphone.

I’m sure the microphone is not broken since it works perfectly on Windows and Mac.

I already tried to follow a few given solutions found on the web but without success.

Any idea on why it’s not working?

Thank you!

You didnt mention which version ubuntu you are using.

If 22.04 do try the live usb session of 22.10 to see if the newer kernel + pipewire resolves your issue.

Since this is a generic ubuntu issue the wider ubuntu community can help as well … askubuntu.com and ubuntuforums.org

You’re right.

I’m actually using:

  • Ubuntu version: Ubuntu 22.04.1 LTS (run lsb_release -a in terminal)
  • Kernel version: 6.0.9-060009-generic (run uname -r in terminal)

I tried the live USB of Ubuntu 22.10 just yesterday but nothing…

It could be just that this is a model that no one yet in the linux world has invested the time to make the mic hardware variant linux compatible.