Webcam microphone not recognized by settings or applications but is recognized by alsa

My webcam’s microphone isn’t recognized by settings (not available under sounds - input) or applications (e.g., Teams, which is where I need it).
It is recognized by alsa, and I can change its gain via alsamixer.

Where do I go from here for troubleshooting? (I don’t know much about audio in linux, but I’m comfortable with a command-line.)

My webcam is a Logitech C920.

I’ll attach the output of alsa-input.

Here’s an image of audio input settings (missing webcam mic as an input):

Here’s the output of alsa-info:
alsa-info.txt (40.8 KB)

This Q&A mentioned your model - but it was referring to 18.04

You could try the answer though to see if makes a difference:

sudo modprobe snd_usb_audio

Thanks. I’ll see what I can figure out.
BTW, that mod already appeared in lsmod. I did the modprobe anyway, didn’t help.

Hmm. It seems to be working now, but I’m confused.

I previously tried both audio input sources (OrbiCam analog and spdif), and neither produced any audio signal. And I got an error from Teams about audio not working. Teams correctly identifies my camera as “HD Pro Webcam C920” but my audio is described as “OrbiCam Analog Stereo” (similar to what’s in settings).

Alsa recognized my audio as HD Pro Webcam C920 (no mention of OrbiCam).

Anyway, it worked fine in arecord, and in Sound Recorder, and now in Teams.

Not sure why it didn’t work before, but it works now.

The names displayed in audio settings are confusing because they don't match the hardware names.