Home Store Blog

Microphone and Headset Issue


#1

Hello,

when I plug in my headset, Ubuntu Budgie doesn’t seem to recognize it is a head set and makes only the headphones part work.

I found various solutions for Linux mostly modifying some lines in /etc/modprobe.d/alsa-base.conf
I have different lines there or the given fixes simply don’t fix anything.

I also have built-in microphone, which hasn’t worked since I changed some settings in Windows (stopped working on both operating systems and not even reinstall helped, just strange sounds are coming of it)

Can you help me with any of these issues (headphones preferred)?

Thank you for your attention,
Karel


#2

This does sound like a more general Ubuntu / linux issue - i.e. not UB specific.

Think it deserves a much wider audience - suggest raise a question on either/both ubuntuforums.org and/or askubuntu.com


#3

I’ve had similar Linux problems in the past. As a result a few years ago, I bought a model that people posted always seemed to work and I’ve had no problems since… I’ll look it up when I get home.


#4

Ok, the headset I’m using is the Logitech USB Headset H390 with Noise Cancelling Mic. It connects via USB-A port. Great sound quality, and it’s worked OOTB on every Linux setup I’ve had. Good luck!