Panel spacing: there's extra space at bottom (right)

I just installed 20.04 (coming from 18.04). I use the panel on the right. Unfortunately, there is extra space at the bottom rather than the “end” items appearing at the end of the panel. (I’ll attach an image if I can.)
There is no spacer after the end item (which is the Raven Trigger, but it doesn’t matter if I move something else there like Clock).

Does anyone know how to fix this? (Seems like a bug, but maybe it’s fixable via configuration. I hope so.)

Notice the large amount of blank space at the end (bottom) of the panel.

Edit: note: this image is just of the bottom-right part of my screen. The items you see in the panel are all in the “end” position (not the “center” postion). And there is no Spacer item after the Raven Trigger.

By default, when you add an applet to a panel, it’s located in its center part.

You may select an applet in the list and then move it to beginning or end of panel :

Here there is no applet in center part.


Thanks. I’m familiar with that. (And I’ve tried with and without something in the center position.) The issue is that items that are in the “end” position are staying far from the end, as seen in the image I posted.

Note: this wasn’t an issue in 18.04. I only see it now that I’ve installed 20.04.

I cannot reproduce this. I added a new panel - set that to be a right hand panel - and then added the icon-task-list applet and moved to the bottom.

Suggest reset your panel - see if there are any warnings reported when resetting occurs - before creating/moving the panel to the right.

nohup budgie-panel --reset --replace &


I have rebooted a few times since installing and configuring my panel. I would guess that’s as much of a reset as the nohup command. (Or am I wrong?)

Rather than adding a new panel, what happens when you try to switch your single panel to the right? (I only have one panel.)

No - rebooting isn’t the same as a reset. If you have uninstalled any applets that a particular layout needs then the panel positions of applets will go screwy. All applets for a particular layout needs to be installed - they don’t necessarily need to be actually on the panel though.

Yes - I’ve tried both ways - moving the main panel to the right as well as a second panel.

Yikes! I didn’t realize that comand would restore defaults. :frowning:

Anyway, it didn’t help. After moving back to the right, it’s still broken.

hmm - so tell me more about your system and setup.

Multiple monitors? If so monitor arrangements in Settings - Displays?

Screen resolution(s).

Single monitor. 1920x1080.

The issue happens on Left as well as Right. Not Top or Bottom.

Ok, you know sometimes it’s safe to start with obvious details, lol.

May you post your list of applets in that panel, as it appears in Budgie Desktop Settings ?

Any ppa on that system ?

No PPA. It’s a fresh install, only thing I’ve added is Teams. (But the problem was there before I added it.)

Note: I did a minimal install (no office etc.). I added Rhythm box back in.

ok - thanks. I’ve added your layout and I can now reproduce the issue.

It appears to be the network applet that is causing the issue. Moving the applet to the center fixes it.

As to why - dunno - that will need to be investigated further.

Raised this issue to track.

Thanks! I’ll move the network as a workaround. I guess you also noticed that moving network to the top causes the similar issue with the top group.

you can test a fix now via our daily ppa. If you can confirm we will ensure it is included in a future update for 20.04

sudo add-apt-repository ppa:ubuntubudgie-dev/budgie-extras-daily
sudo apt upgrade

Log out and login

To revert after testing

sudo ppa-purge ppa:ubuntubudgie-dev/budgie-extras-daily

Log out and login

I confirmed it works as expected with the PPA. Thanks!