Displaced applets

After a Budgie crash on my 20.10 system while doing online classes, logging back in reveals that the applets have become misplaced. Raven launcher appears at the end of the panel, but Budgie Desktop Settings says it appears before the three last applets (network, status indicator, and user indicator) it’s supposed to be ahead of. Weirdly enough, after a restart, the Raven launcher is now behind the applets that it’s supposed to be ahead of, and now panel settings reads the applet as the last applet of the panel…
Worse yet, if I do try to fix it by deleting the applet and replacing it, upon reaching the last three applets above, the move down/right button is greyed out, as if the panel hit a dead end. It also messes up the arrangement of the other applets, basically enough to give you headaches. Below is a picture of what I mean.

Look at the top right corner, then look at the applet layout as seen on Desktop Settings,

This has annoyed me so much. I restarted many times, tried to xkill the panel, attempted to reinstall the desktop, all to no avail. I’m on the brink of reinstalling or even distro hopping all together. Please help. Thanks.

Ok. What is likely to have happened is that you have at some point uninstalled one or more of the default applets.

The panel layout is struggling because it is looking for applets are not there…


that the crash has corrupted the dconf settings.

First of all double check that you have still got all the default applets installed. You dont need them on the panel.

Next reset your panel to fix the corruption caused by the crash

nohup budgie-panel --reset --replace &

Then fix up the panel to have the applets you want.

That actually worked