Printers and Budgie

My Canon MX490 only works on my wireless connection where my LAN name is recognized, but when I open Printers in Budgie it says my server is Local Host which my Netgear router often dismisses on my wired connection I find instructions for changing the Local Host to your LAN on earlier editions of Umbutu but not on Budgie

have a look at this, I think the printer drivers are ubuntu related, not specific to the ubuntu budgie DE.

about 3/4 the way down, there are instructions for installing CUPS through the terminal, although you may already have it installed.

Jason I have the CUPS driver installed the issue seems to be that it still says the server is Local Host, which it is not I’ll try configuring my router to give both my printer and my Dell Latitude static Addresses. Thanks, Jason, I think it is related to all linux/ubuntu DEs the same thing happened on my HP Compaq CQ57 running Linux Mint 19.03. All other internet functions work - except the printer! which has me mystified :woozy_face:

Out of curiousity, have you tried adding the printer through CUPS instead of through the Printers in Budgie? Mine (cheap Samsung laser) works perfectly on 20.04 but initially on 19.10 I had trouble getting it installed on one of my machines for some reason.

More network options to connect to my printer showed up on
than showed up in Printers settings…

My own personal experience:

I have a house of (mostly outdated) Apple products. Our Brother printer is attached to a mac mini with a USB cable. Everyone prints to the printer that was previously found on the network (I can’t remember if I needed to install drivers? Probably not), and then I run to the printer and “wake” the mac mini. The mac mini waits a moment to reacquire the wifi connection then prints. This is all on various versions of macOS. The file gets sent on the network before the printer is active. The file knows to print to my brother printer. This may be because I have a brother driver installed.

On my Ubuntu Budgie laptop, it’s a very similar process, but the printer likes to be active/awake BEFORE I print. The text program wants to see where to print before sending a print file.

Do you need to set the Dell Latitude to “never sleep” or something so it is always active/never sleeps? I’m hardly a genius, but I wonder if you are over-thinking this, imagining worst case scenarios. Try this before messing with router configurations.

Sorry: I just reread that. Is your Dell the printer is connected to a Windows machine? There are a number of hoops to jump through to print from Linux to Windows that have nothing to do with routers. Apple and Linux both use CUPS and Windows does something else.

Thanks, samlane worth a shot

Jason, it is a Canon MX490 attached to my wife’s HP running Windows10, and using Office365. She is a teacher and uses it to work from home, as it is integrated with her school, it is set to share, but I will not buy a Canon again as it has been touchy since we bought it, but thanks. I really hesitate to make many changes in her system.

Well, that attached article suggests … Samba? I wonder if you could simply email the print files to her laptop, then print from within Windows 10 (ugh) I think the limitation of the printer sharing is an issue with Windows, not the fact that it is a Canon – although I hear you that you think it’s a bit dodgy.

OR: you could (literally) pull the printer cable from her laptop, plug it into your device, print, then plug it back into your wife’s laptop. Nothing beats a printer cable! I am always shocked that so few people have printers at home, and nobody seems to like the printer that they have. I love my inexpensive laser printer :slightly_smiling_face: