Screen glitching problem with 20.04

Hi, I’m new to Linux and Ubuntu. For some reasons I ended up installing Ubuntu Budgie 20.04 in my Asus x505za and there is a problem:

I start Ubuntu and everything works just fine but my screen glitches a little bit. It is a constant glitch but it seems to be no real problem so i don’t really understand what is going on.

My specifics are:

Processor: AMD Ryzen 5.
RADEON vega graphics.

That computer has no more than 2 years of regular use in Windows.
I must say that I have no experience with computers.

Thank you in advance.

Please post the output of this command from the terminal;

inxi -G

Thank you very much for your quick response. After typing that command in the Tilix:

Device-1: AMD raven Ridge [Radeon vea Series / Radeon Vega Mobile series]
drive: amdgpu v: kernel
Display: x11 server: 1.20.8 driver: admgpu, ati
unloaded: fbdev, modesetting, vesa resolution: 1366x768 ~ 60Hz
Open Gl:
renderer: AMD RAVEN (DRM 3.35.0 5.4.0-31-generic LLVM 9.0.1)
v: 4.6 Mesa 20.0.4

Okay, next thing;

sudo mkdir /etc/X11/xorg.conf.d
sudo nano /etc/X11/xorg.conf.d/20-amdgpu.conf

add the following;

Section “Device”
Identifier “Radeon”
Driver “amdgpu”
Option “TearFree” “on”

save: [ctrl]+[o]
Exit: [ctrl]+[x]


I have upgraded Ubuntu Budgie Linux from 18.04 LTS to 20.04 LTS…all is fabulous EXCEPT my HP Probook 650 has serious screen glitches.
the current output to inxi -G:
Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915
v: kernel
Display: x11 server: X.Org 1.20.8 driver: intel tty: N/A
OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2)
v: 4.5 Mesa 20.0.8
After some digging I tried several iterations of 20-intel-graphics.conf and find that none of them resolve the problem.
Inputting the Option “AccelMethod” “uxa” froze the boot and I had to remove the file AND xorg.conf.d directory.
A simple file with:

Section "Device`
Identifier  "Intel Graphics``
Driver      "intel"```
Option      "TearFree"     "true
End Section

Note: TearFree option is 'true' not 'on' in my working fix.

Seems to at least boot. .. it has not solved the screen problem. 
The problem is not 'tearing' as I see from most websites talking about this.
Rather the screen goes to flickering and distortion
 ( Once I figure out how, I will attach an image file). 
None of this occurred with Budgie 18.04.

I have the exact same problem, with the i915 also. If you are interested, the bug report is here:

Unfortunately, I don’t know why the issue still persists when you try the intel driver / tearfree option. I was lucky enough that it fixed it for me. Here is the exact contents of /usr/share/X11/xorg.conf.d/20-intel.conf on my system:

Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    Option "TearFree" "true"
    Option "AccelMethod" "SNA"

Thanks @samlane!

I note your config file is in a different place /usr/share/X11/xorg.conf.d/ where as all the instructions on line were for /etc/X11/xorg.conf.d/

I will try moving the file and seeing what happens…perhaps that will work in itself. If not I will add the AccelMethod option.

Thank you again for replying!

Here is an update…
I am looking at abandoning Budgie Linux.
I have tired creating and installing the 20-intel-graphics.conf; then 20-intel.conf. I tried placing either of these in /etc/X11/xorg.conf.d/ or usr/X11/xorg.conf.d/
I have tired the purge intel graphics suggestion; the purge xorg server suggestion; the updating of drivers (again and again and again)
I have tried to install the intel drivers and the intel ppa.
Any spelling mistakes on the path or files is due to fatigue and frustration …and well after weeks of trying…I give up.
NOTHING stops the screen from becoming unusable for up to 60 seconds at a time.;
My research tells me this is not a Budgie Linux issue but a Ubuntu and derivative issue with intel graphics since version 20.04.
I was willing to try “wayland” but find absolutely nothing that relates to Budgie on how to install or configure this.
If I could figure out how to attach a file I would share the image of the screen…
My best hope is to go back to version 18.04 and hope I can still use my data. Sadly I will have to rebuild everything from scratch.

Suggest try the new mutter version currently in the proposed repo.

  1. Menu - Software Sources

  2. On the developer tab - enable pre-released updates

  3. Click close - then click the “Reload” button when requested

  4. Open a terminal and type

    sudo apt install libmutter-6-0

  5. Reopen Menu - Software Sources, untick the pre-released updates checkbox and click reload again when prompted

Logout and login.

It said that the libmutter-6-0 was already the latest version…

If you have successfully enabled the proposed repo using the instructions above the version of libmutter should be 3.36.7+git20201123-

I have installed the new version. Currently the screen distortion is still happening. I am attaching an image of the screen…

I will try to figure out the version of libmutter and get back to you. Though now the distortion is taking most of the screen time…so worse than before.

More to follow


If I use sudo apt-cache policy mutter (libmutter is not available or does not exist)

I get:

Installed: (none)
Candidate: 3.36.6-1ubuntu0.20.04.2
Version table:
3.36.6-1ubuntu0.20.04.2 500
500 focal-updates/main amd64 Packages 3.36.1-3ubuntu3 500 500 focal/main amd64 Packages

Sorry…here is the read out David:

Reading state information… Done
libmutter-6-0 is already the newest version (3.36.7+git20201123-

Well, my apologies because originally it sounded like you were having the same issue as me, since I am also having graphical issues with the i915. Looking at you screen, what I have is not even close to that. What I am getting is way less severe:


Seems like you have something different going on. Sorry :slightly_frowning_face:

I really appreciate your wanting to help. I have run out of options… i think I will go back to Budgie 18.04 …that worked perfectly.

Take gentle care of yourself.


Hi there, i saw your questions about the amd ryzen (raven graphics glitchs), when i was using Solus Budgie i had the same behaviour in a huawei matebook with ryzen5 2500, i was able to correct it changing the boot parameters, in ubuntu budgie you need to change your default grub options from “quiet splash” to “quiet amd_iommu=on iommu=pt idle=nomwait splash” (sudo nano /etc/default/grub) and after do a sudo update-grub . These parameters for me took out any glitch i had on firefox or even in normal desktop apps.

Hope this is the fix for you aswell.

1 Like

I’m not sure it’s the same bug but I have [ Windows flicker when resizing](

It’s said here that

Upstream has closed the bug because it stopped happening with:

mutter 3.38.2 + Xorg 1.20.10

Any idea when it will be fixed in Ubuntu Budgie?

It’s said here

You can see here that 3.38.2 is currently in the proposed repo undergoing testing

Assuming that is passes testing then it will be released to the main repo. That testing activity can take around 7 days to a few weeks depending if testing throws up any issues