Home Store Blog

Graphics Issue with Budgie 18.04, AMD and Intel Integrated


#1

I’ve been experiencing some weird random graphical glitching after doing a fresh 18.04 install. Anyone have a clue? I’m running an AMD Radeon RX550 and onboard Intel graphics using open-source drivers.

Screenshot


#2

I’ve seen the graphical glitches like this. I too have the same card as you but in my case it only last for 10 seconds.

https://help.ubuntu.com/community/AMDGPU-Driver


#3

I tried the AMDGPU-Pro driver, but the issue I have is that if I do that, I can’t seem to make the onboard Intel graphics chip work with it. I’m not entirely sure, but it might not be supported. Correct me if I’m wrong.

I did not have this issue under Budgie 16.04 LTS.


#4

My understanding is that the AMDGPU-Pro driver is being deprecated - much more focus on the open amdgpu stack by AMD themselves. Suggest stick with that.


#5

That’s what I’m planning to do anyways. I do think it might have something to do with Mesa. I’ve tried the git-release of Mesa (18.2.0-devel) and the graphical glitching seems to be worse, causing entire sections of the screen to just go white in addition to the glitching shown in the screenshot. Like I said earlier, AMDGPU-Pro doesn’t exhibit any of the issues, but of course I don’t want to use it since I lose a monitor (and it being deprecated, of course). I’d like to keep this FOSS.


#6

To help along, here’s what I have (before updating to 18.2.0-devel version of Mesa).

> lspci -nn | grep -E 'VGA|Display'
00:02.0 Display controller [0380]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller [8086:0162] (rev 09)
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Polaris12 [1002:699f] (rev c7)

> sudo lshw -c video
  *-display                 
       description: VGA compatible controller
       product: Polaris12
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: c7
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=amdgpu latency=0
       resources: irq:26 memory:e0000000-efffffff memory:f0000000-f01fffff ioport:e000(size=256) memory:f7e00000-f7e3ffff memory:c0000-dffff
  *-display
       description: Display controller
       product: Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm bus_master cap_list
       configuration: driver=i915 latency=0
       resources: irq:31 memory:f7800000-f7bfffff memory:d0000000-dfffffff ioport:f000(size=64)

> glxinfo | grep Mesa              
client glx vendor string: Mesa Project and SGI
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.0-rc5
OpenGL version string: 3.0 Mesa 18.0.0-rc5
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.0.0-rc5
`