Set gnome-terminal in Open Terminal, 19.04

Running Ubuntu Budgie 19.04. Cinnamon’s right click to open X in terminal is set for Tilix which I do not use, how to set it for gnome-terminal?

1 Like

Errr… explanation needed : what does Cinammon stand here for ?

In UBudgie 18.04, the feature you mentioned ( open with Tilix ) is provided by /usr/share/nautilus-python/extensions/open-tilix.py

So installing something like nautilus-extension-gnome-terminal would provide an « Open with Gnome terminal » feature.

I guess it’s kind of the same way with nemo in UBudgie 19.04, which also uses python extensions, assuming such a nemo-extension-gnome-terminal exists… or maybe nautilus and nemo share same extensions, I don’t know.

Oops, I meant Nemo, not Cinnamon. Brain fart of the most supreme order.
Yeah, the context menu option says Open in Terminal but it won’t open gnome-terminal, only Tilix which I don’t like therefore I’m using gnome-terminal.

There’s probably an extension ( python script ) for Nemo somewhere to do what you want, open gnome terminal.

There are several sources on the internet, explaining how this works by using the following command :

sudo update-alternatives --config x-terminal-emulator

I have tried this on my machine, but whatever option I choose, the effect is null. The only terminal that pops up is Tilix.

Another thing I tried was :

 gconftool --type string --set /desktop/gnome/applications/terminal/exec gnome-terminal

With the same result that only Tilix pops up.

Any idea why this happens?

gconftool is obsolete. Try

gsettings set org.cinnamon.desktop.default-applications.terminal exec 'gnome-terminal'

Thanks bro. Fixed it for me, back to Nemo.