Home Store Blog

Nemo "open in terminal" does not work


#1

Hi,

I’m using nemo as my default file manager.
However, the button “open in terminal” does not open tilix, instead nothing happens when I click it. If I remember correctly, it did work on my laptop.
Is there a place where I set this up? Open in terminal works correctly in nautilus.


#2

Seems the default is to open gnome-terminal

Odd. Very odd. Found this on Unix SE… so have an experiment with the gsettings key that it mentions


#3

hey, thanks for your reply.
I’ve tried to set it via
gsettings set org.cinnamon.desktop.default-applications.terminal exec 'tilix'
suggested here as well as

gsettings set org.gnome.desktop.default-applications.terminal exec tilix

But in both cases I get this message:

GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

(process:5633): GLib-GIO-WARNING **: unknown schema extension 'd'

(process:5633): GLib-GIO-WARNING **: unknown schema extension 'd'

and the value does not get saved. any idea?


#4

I’ve installed gnome-terminal and nemo opens that. so I’ll have to change the gsettings for org.cinnamon.desktop.default-applications.terminal somehow.


#5

A quick Google for the memory message reveals a variety of possible causes. I don’t know what your setup is. For example do you have a different python installed from default? Do you have custom binaries that you have built?

This?

The tilix gsettings is definitely the way to go here.

Maybe you can use dconf-editor to edit that value manually


#6

I got it, thanks! I’ve also came across something matplotlib related, but I thought that can’t be related.
The problem was that my anaconda env with python 3 was the first python in my path.

So here is the full solution:

  1. make sure the default python is the first in your path
  2. then run gsettings set org.cinnamon.desktop.default-applications.terminal exec tilix

After that it worked.
Btw the terminal shortcut ctrl + alt + t does often not work. Do you have any idea why?


#7

well found!

For ctrl + alt + t see this thread … and suggestion Volume up-down, calculator, ctr-ALTl T, windows key +A and more, not working anymore