Home Store Blog

Change default terminal to hyper and in right click menu 'open tilix here' as tilix is having rare bug of not able to type something after sometime

#1

Please help i have been looking for a solution

#2

Hi and welcome

I have no idea what “hyper” is - but assuming it is an x-terminal-emulator like gnome-terminal and tilix then running:

sudo update-alternatives --config x-terminal-emulator

This will list all the terminals you have installed and you can choose which one you want to default to for every user account installed on your system

Alternatively use dconf-editor and modify this key org.gnome.desktop.default-applications.terminal to point to which terminal you are using for just your logged in user account.

Note: The “open tilix here” is a nautilus/nemo action so you will need to code that yourself.

1 Like
#3

Hi @fossfreedom

Thank you for your help.Yes Hyper is a terminal,do check it out, I think it should be the default terminal,
I checked and found budgie has nautilus. you said i need to code that myself,but i am a noob ubuntu user so i hardly can,but i am finding a way to do i hope it doesn’t lead any issue in stability, i went i ‘Preferences’>>‘Menu Editor’ , there i found tilix is in a category of X-GNOME-Utilities. but i cannot add ''X-GNOME-Utilities" in hyper. am i doing correct please help me