Slow Application Startup

After the latest kernel update on Ubuntu Budgie 19.10, a number of applications now take about 30 seconds to load. These include SMPlayer, VLC and Recoll. Before the latest kernel update, these applications worked ok.
I assume that this may be a hardware problem since I have not seen this problem reported in discourse to date. The strange thing is, that in Ubuntu 19.10 these applications work perfectly.
I may have to wait until the next kernel update, but any suggestions would be appreciated.

VLC startup was reported to us a few weeks back and I made this suggestion

You can confirm if it definitely is a kernel issue by booting from the earlier kernel via grub.

Please file a bug report

ubuntu-bug linux

I have the same issue with applications like VLC, Krusader, Virtualbox…
Tried to install gir1.2-rsvg-2.0 as you mentioned but couldn’t help…
Also for me it’s the same with kernel 5.3.0-18 and 19… so since I’ve installed 19.10…

When I am starting these its like the icon come up on plank (no window visible) then after 10sec it’s going away and the application starting in around another 20sec

I have exactly the same issue with vlc and some other applications. This is only related to Budgie as I have tested both Ubuntu 19.10 and Ubuntu Mate and I have not experience this. I really want to stick with Budgie as it is has been my favourite distro.

I had to go back to 19.04 because of this issue… it was a bit unusable for me.
But same as Lars, Budgie is my favourite distro and wouldn’t change if not necessary…

Think this is a QT issue.

Please purge the package qt5-gtk2-platformtheme and try to run those apps taking a long time.

If they work - please reinstall that package above and then report the issue to launchpad so that the QT maintainers are made aware:

ubuntu-bug qt5-gtk2-platformtheme

You can purge that package again after reporting the issue.

well done, removing the package qt5-gtk2-platformtheme does fix the slow application startup problem.

unfortunately I do not have an Ubuntu One account, so I can’t report the bug.

I suspect that the bug would not be given a high priority, since it only affects Budgie.

It will affect any GTK based desktop environment - gnome-shell included if that package was installed

fossfreedom

As you suggested that if the package were installed in any GTK based environment, I installed qt5-gtk2-platform theme in Ubuntu 19.10 and rebooted. SM Player, Recoll and VLC all opened as normal.

To be fair, my version of Ubuntu does not actually use the package and that is may be the reason this package shows no effect.

I would like to register for an Ubuntu One account, but while I was registering my account, there was a power cut. I deleted the account and reregistered, apparently. However whenever I try to go into Ubuntu One, I get the message “oops something went wrong”.

I shall continue to use and contribute to Ubuntu Budgie and I really appreciate the hard work both you and the rest of the team put into the project.

thx.

For more info - I could not reproduce the issue on a live session 19.10 - only when 19.10 was installed.

There is a QT transition going on at the moment in 20.04 with a brand new QT version release - once it finishes will check if the issue reoccurs.

If it does still occur then I will drop all of the QT - GTK theming integration packages we ship with - this package / style plugins. Remember - 20.04 is all about stability!

Thanks a lot.
It solved the problem. I just removed it without reinstalling it and solved the issue.
I also reported it, hopefully, it is fixed in the future.
Thank you for very much for developing the wonderful Ubuntu Budgie :slight_smile:

1 Like