Firefox in 19.10 is kind of slow to get ready


I recently installed a 19.10 UbuntuBudgie. I was using 18.04 ago.

Since this new installation I’ve noticed Firefox is kind of slow to « start » :
⋅ I can launch Firefox but it’s unresponsive for a moment ( no blinking cursor anywhere )
⋅ then cursor eventually appears in address bar but blinking slowly and not usable,
⋅ still, clicking anywhere has no effect, or effect delayed much later,
⋅ a moment later, cursor blinks at its usual pace and Firefox becomes responsive as expected.
The whole process takes 30 seconds to 1 minute and Firefox runs rather ok later on with some slow moments though.

Same behavior in safe-mode ( without any FF addons ).

(firefox:17653): LIBDBUSMENU-GTK-CRITICAL **: 21:52:24.565: dbusmenu_menuitem_property_set_shortcut: assertion 'gtk_accelerator_valid(key, modifier)' failed

(firefox:17653): LIBDBUSMENU-GTK-CRITICAL **: 22:07:18.480: dbusmenu_menuitem_property_set_shortcut: assertion 'gtk_accelerator_valid(key, modifier)' failed
django@ASGARD:~$ firefox --safe-mode 

(firefox:19093): LIBDBUSMENU-GTK-CRITICAL **: 22:08:02.177: dbusmenu_menuitem_property_set_shortcut: assertion 'gtk_accelerator_valid(key, modifier)' failed

I use Budgie applets : pixel-saver and global menu. Guess it’s related ?
→ maybe not related, even without these budgie applets, FF still shows the exact same error.
[ edit 2020-04-04 ] → my big mistake here → one has to logout / login back to session after each modification on applets / panels !!!

Well I think we can start there. Did you test that?

I edited my post - meaning I have tested without applets and problems ( message in terminal + slowness ) still there :wink:

Nota also, I did not have those problems in UBudgie 18.04.

If of any interest @bashfulrobot :

@Coeur-Noir thanks! I’ll have a look. This is likely upstream though (suspect based on URLs). :grin:

Appreciate the links.

First link is old, 2011.

Second is mine, 2020-03-29.

And no surprise, I don’t have these problems in 16.04 with FF74.

Disabling hardware acceleration in FF does not change anything.

Another example of « glitch » is in twitter, when clicking on a picture, it kind of flashes / gets half transparent ( maybe more related to SuperTuxKart in 18.04 : flickering shadows with intel i915 )

Nobody’s noticed the same ?

On everyday’s usage it becomes a real pain…

I have not seen this at all. FF opens up almost immediately for me. (See the GIF). I had been trying to replicate - but I can’t seem to mimic your behavior.

Mmm… I’ll try with a new profile.

…same with empty FF profile.

Problem here is, as long as Firefox has not finished its starting, all interactions with Budgie desktop are also slowed down ( if I click anything in panels, it will react only after FF is completely ready ).

Adding some info, as did there

CurrentDesktop: Budgie:GNOME
Date: Fri Apr 3 02:04:06 2020
DefaultProfileExtensions: extensions.sqlite corrupt or missing
DefaultProfileIncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
DefaultProfileLocales: extensions.sqlite corrupt or missing
DefaultProfilePrefErrors: Unexpected character ',' before close parenthesis @ /usr/lib/firefox/omni.ja:greprefs.js:732
DefaultProfileThemes: extensions.sqlite corrupt or missing

Any thought about these corrupt or missing mentions ?

Checked the twitter flickering pictures issue but can’t reproduce it either … everything normal with Firefox at this part of the quarantine…

Regarding slow starting and LIBDBUSMENU-GTK-CRITICAL → I don’t have them if I launch Firefox as downloaded from Mozilla site as a standalone.

Firefox starts instantly here even after a new 19.10 clean install. On a Core i3-9100.

Please launch Firefox from terminal and see if any error message.

Launch is fast - but with a frozen unresponsive whole interface for a long moment.

It seems there is a problem in my installation but sudo apt install --reinstall firefox did not help.

Since Firefox downloaded from Mozilla’s page works without error, I have some hope to find out what went wrong ( file omni.ja ? )

If of any interest, here are my installed dbus packages :

    django@ASGARD:~$ dpkg -l | grep dbus
    ii  at-spi2-core                          2.34.0-2                               amd64        Assistive Technology Service Provider Interface (dbus core)
    ii  dbus                                  1.12.14-1ubuntu2                       amd64        simple interprocess messaging system (daemon and utilities)
    ii  dbus-user-session                     1.12.14-1ubuntu2                       amd64        simple interprocess messaging system (systemd --user integration)
    ii  dbus-x11                              1.12.14-1ubuntu2                       amd64        simple interprocess messaging system (X11 deps)
    ii  libdbus-1-3:amd64                     1.12.14-1ubuntu2                       amd64        simple interprocess messaging system (library)
    ii  libdbus-glib-1-2:amd64                0.110-4                                amd64        deprecated library for D-Bus IPC
    ii  libdbusmenu-glib4:amd64               16.04.1+18.10.20180917-0ubuntu2        amd64        library for passing menus over DBus
    ii  libdbusmenu-gtk3-4:amd64              16.04.1+18.10.20180917-0ubuntu2        amd64        library for passing menus over DBus - GTK+ version
    ii  libdbusmenu-gtk4:amd64                16.04.1+18.10.20180917-0ubuntu2        amd64        library for passing menus over DBus - GTK+ version
    ii  libnet-dbus-perl                      1.1.0-6                                amd64        Perl extension for the DBus bindings
    ii  libqt5dbus5:amd64                     5.12.4+dfsg-4ubuntu1.1                 amd64        Qt 5 D-Bus module
    ii  libqtdbus4:amd64                      4:4.8.7+dfsg-7ubuntu3                  amd64        Qt 4 D-Bus module library
    ii  python3-dbus                          1.2.12-1                               amd64        simple interprocess messaging system (Python 3 interface)
    ii  python3-dbus.mainloop.pyqt5           5.12.3+dfsg-2                          amd64        D-Bus Qt main loop support for Python 3
    ii  xdg-dbus-proxy                        0.1.1-1                                amd64        filtering D-Bus proxy

Is it normal to find libdbusmenu-gtk4:amd64 already installed by default ?

Going on on my experimentations with « pure » FF from Mozilla, I’ve noticed :
⋅ it does not throw any errors regarding libdbusmenu ( even with my older profile⋅s )
⋅ but it does not export app-menu to Budgie global menu applet…

And going further, is it normal there is no .dbus folder in any of users’ personal folder of Ubuntu Budgie 19.10 ???

Edit,later : on 20.04 tested on live usb, there is a .dbus folder…

Have you tried reinstalling Firefox by chance?

Yes, I did try. Not better.

Weird. Any thought about .dbus folder missing ?

I went poking around, and I found a very similar bug (sqllite extension) on regular Ubuntu (and not just budgie).

Have you tried to see if there are any bugs on the Mozilla tracker for this?

Not the same problem, I have never had errors regarding profiles.

I even have tested with different profiles, empty profiles, new profiles.

I always have the (firefox:17653): LIBDBUSMENU-GTK-CRITICAL **: 21:52:24.565: dbusmenu_menuitem_property_set_shortcut: assertion 'gtk_accelerator_valid(key, modifier)' failed error message in terminal. This added to the fact I don’t have .dbus folder in my personal folder sounds not good and related…

And also this in dmesg :

[  607.797925] budgie-panel[1671]: segfault at 0 ip 00007ff290bc8e57 sp 00007ffd2ac8ba00 error 4 in[7ff2909ea000+36e000]
[  607.797930] Code: ef f8 ff ff 41 01 c5 83 c2 01 44 89 6c 24 24 41 39 d6 75 df 8b 4c 24 18 85 c9 7e 69 31 db 0f 1f 44 00 00 49 8b 3c 24 48 89 fe <4c> 8b 3f e8 d1 cf e2 ff 49 89 04 24 4c 89 ff e8 b5 f8 ff ff 4d 85

Bad chance ?

Or this is much longer :

django@ASGARD:~$ cat /var/log/syslog | grep -i error

→ here →
with many mention of gdbus, ayatana, unity, budgie-panel, gtk…

The constant accelerator messages is a fix in 20.04

If you create a new account with no changes do you have the same firefox launch issues