Slow Ubuntu Budgie Boot

After installing 19.10 alongside Windows 10 on my Asus Notebook, I expected the boot time to under a minute. Instead, it is 1 min and 15 seconds.

Is this normal for a laptop with a HD (no SSD, still)?

systemd-analyze blame returns :

     27.834s systemd-journal-flush.service
     20.529s dev-sda5.device
     18.226s snapd.service
     17.288s networkd-dispatcher.service
     14.839s udisks2.service
     13.805s NetworkManager-wait-online.service
     11.923s accounts-daemon.service
      9.684s ModemManager.service
      9.038s systemd-resolved.service
      8.998s gpu-manager.service
      8.906s vboxweb.service
      8.753s e2scrub_reap.service
      8.660s mono-xsp4.service
      8.530s grub-common.service
      8.210s secureboot-db.service
      8.106s apport.service
      7.849s avahi-daemon.service
      7.694s plymouth-read-write.service
      7.662s NetworkManager.service
      7.659s bluetooth.service
      7.659s wpa_supplicant.service

There is also a boot screen with a long line of message that I find difficult to interpret:

That is indeed slow - and maybe those PCIe errors are the key (hopefully)

Does anything here (suggest also read the comments) help?

Great many thanks, adding pci=noaer to the GRUB solved the problem with the PCI Bus.

The boot time stills remains the same, though.

1m 15s is perfectly normal for a HDD, at least for me. What was Win10’s boot time?

Found this article about the above service - worth a try boot - What is the use of systemd-journal-flush.service? - Ask Ubuntu

Worth re-running systemd-analyze blame after dealing with the above.

Windows 10 boot time is only 35 seconds … a lost faster

1 Like

Hmm, VERY fast for a HDD. Check @fossfreedom’s posts above, please. They tell you some system services you can shut down to make boot faster ;p

Thank you, guys, for your efforts.

I have looked at the system-service solution here before, and, even it is possible, it is not recommended to disable the service, since it obviously has a utility, or wouldn’t be there.

System-analyze blame reveals that the process which takes the longest time to load, is


According to the recommendations from ask-ubuntu, I tried:

sudo journalctl --vacuum-size=1G --vacuum-time=5d --vacuum-files=5

But, to no avail.

I find the idea to disable services in order to gain a couple of seconds, concerning. I guess there is a high probability to mess up the system and sometimes undo certain actions is not that easy.

It just would be nice to have a slicker boot …