[Solved] - Budgie 22.04 - space between time and date

Greetings to the forum.
I use Ubuntu Budgie 22.04 on my pc-desktop.
on the top panel the time and date are very close together and I would like to move them away from each other by a few mm.
Here my system info:

apanta@apanta-desktop:~$ inxi -FZA
  Host: apanta-desktop Kernel: 5.19.0-35-generic x86_64 bits: 64
    Desktop: Budgie 10.6.1 Distro: Ubuntu 22.04.2 LTS (Jammy Jellyfish)
  Type: Desktop Mobo: ASRock model: K10N78FullHD-hSLI..
    serial: <superuser required> BIOS: American Megatrends v: P2.30
    date: 04/30/2010
  Info: dual core model: AMD Athlon 64 X2 5200+ bits: 64 type: MCP cache:
    L2: 1024 KiB
  Speed (MHz): avg: 1800 min/max: 1000/2700 cores: 1: 1800 2: 1800
  Device-1: NVIDIA GF106 [GeForce GTS 450] driver: nvidia v: 390.157
  Device-2: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo
  Display: x11 server: X.Org v: driver: X: loaded: nvidia
    gpu: nvidia resolution: 1: 1920x1080~60Hz 2: 1920x1080~60Hz
  OpenGL: renderer: GeForce GTS 450/PCIe/SSE2 v: 4.6.0 NVIDIA 390.157
  Device-1: NVIDIA MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio
    driver: snd_hda_intel
  Device-2: NVIDIA GF106 High Definition Audio driver: snd_hda_intel
  Device-3: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo
  Device-4: TerraTec GmbH Aureon Dual USB type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.19.0-35-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
  Device-1: NVIDIA MCP77 Ethernet driver: forcedeth
  IF: enp0s10 state: down mac: 00:19:66:95:bb:3a
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: 50:3e:aa:0d:94:6e
  Local Storage: total: 4.32 TiB used: 1.28 TiB (29.7%)
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
  ID-2: /dev/sdb vendor: Seagate model: ST2000DM001-1ER164 size: 1.82 TiB
  ID-3: /dev/sdc vendor: Seagate model: ST31000528AS size: 931.51 GiB
  ID-4: /dev/sdd vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB
  ID-5: /dev/sde vendor: Crucial model: CT1000BX500SSD1 size: 931.51 GiB
  ID-1: / size: 49.21 GiB used: 22.29 GiB (45.3%) fs: ext4 dev: /dev/sde2
  ID-1: swap-1 type: partition size: 7.45 GiB used: 0 KiB (0.0%)
    dev: /dev/sda1
  System Temperatures: cpu: 31.0 C mobo: N/A gpu: nvidia temp: 38 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 30%
  Processes: 221 Uptime: 22m Memory: 7.76 GiB used: 2.09 GiB (26.9%)
  Shell: Bash inxi: 3.3.13

I am attaching screenshot of the top panel
Any suggestion will be well accepted

In the settings for the clock applet, you can turn on “Custom Format” and add a space or two between %S and %d. Also you may need to tweak it a little and change the “.”’ to “/” if you prefer the “/” in the dates.

Technically you can customize it even further if you desire:

Anyways, setting is:

1 Like

I think the custom format for the clock was from Kinetic onwards.

@Apanta if you don’t see that option Sam has pointed you towards, there is an applet you can install from menu - budgie-extras called “budgie-calendar-applet” which has the identical capability to custom format the time & date.

Thanks, I’ve already entered top panel settings but it is not possible to add a space or a separator between time and date.
I can only put it before the time or after the date

Yeah, spacers or separators wont help here.

As fossfreedom mentioned, my original answer won’t work on 22.04, so you are best off installing the Calendar applet from Budgie Welcome.


Once this applet is installed, you might want to log out and back in first, but then you can remove the Clock Applet and add the Calendar applet.

In the settings for the Calendar applet, turn on Custom Date. To mimic your current format, you will probably want to enter this instead for the Custom date then fine tune as desired:

%H:%M:%S %d/%m/%Y

But when you change this field, the top panel will reflect it.


1 Like

Perfect. solved the problem thanks to the new applet.
Time-Date ok

1 Like