Strange text on the screen when starting the computer!(?)

Hi all.
MBP early 2011 ‘converted’ to Linux with Ubuntu Budgie 20.04.
Run it more or less perfectly for about a month. Do upgrades regularly (once a week in general).
A week ago something happened when I turn on the computer; When screen is still black and before the login set up is shown, a text in white is seen on the screen. It says;
‘Failed to set MokListRT: Invalid Parameter
Could not create MokListRT: Invalid Parameter
Importing MOK states has failed: import_mok_state0: Invalid parameter
Continuing boot since secure mode is disabled_’

This text is seen for about 3 seconds and then comes the normal login page (‘admin login’).
But even after the first login the text is seen again, but this time for only like 1 sec, then comes the regular login (user name).


Its a known bug:

So thoughts in the comments in that bug report.

I tried this;
sudo su -
cd “/boot/efi/EFI/ubuntu”
cp grubx64.efi shimx64.efi

and it looks like the white text on the black background is gone.

Just be aware when the next bug fix version of grub2 is released your changes will be overwritten.

Yeah - now the ‘problem’ is back from a couple a weeks ago.
Is there a way to get around this?

same solution I would imagine - the grub release in the last couple of weeks would have overwritten your manual changes

Sorry, I don’t understand what you mean.
Same solution as the last time using ‘sudo su -
cd “/boot/efi/EFI/ubuntu”
cp grubx64.efi shimx64.efi
It doesn’t work.

Live with it or take any other action?

Well if that doesn’t work then you will have to wait until the grub issue is resolved.

Hi there. Happy New Year everyone !! I also have a problem similiar to this though the text is a little different. It reads : Failed to set MoklistRT: Invalid Parameter Could not create MoklistRT: IGNU GRUB version 2.04 Importing Mok states has failed:Import_mok_state()failed Minimal BASH-like editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completion

My computer froze on a facebook page becoming unresponsive and for the first time ever, my mouse would not work and I had to do a hard shutdown. When I restarted the computer, I had error messages hardware error CPU; hardware error TSC; hardware error Processor 2.7 etc.

I tried using recovery mode and also a recovery drive but no success. My computer wont even boot to normal log in screen. I can’t get past that error message in grub. I tried a reinstall but it wont boot to either flash drive or DVD. Have looked on the internet for fixes but no success so far.

I am using Ubuntu Budgie 20.04.1. with latest kernel

Any help greatly appreciated. Thanks. Lyndon

hmm - hardware errors are usually the first signs of a failing component - sounds motherboard related.

Thank you so much for your prompt reply. Lyndon