Testing 20.04 - only for the most adventurous

I started using Ubuntu back in 2004.
I have seen allot of changes plus and minus.
I lover gnome shell, and or Unity up until a couple of years ago.
I have been checking many other OS. Including testing betas.
I wanted to stay with the Debian development side with Ubuntu.
The only reason I did not use Budgie earlier is because of Nautilus. I have been using Nemo for years, and love all the functionality it offers.
I have always replaced my desktop FM to nemo, but starting on 19.04 and more prominent on 19.10 the Gnome shell has issues with Nemo.
I am very impresses with Budgie.
keep Nemo, I have used plank for a couple of years and never had an issue.
This is my first time using Tilix, Wow, Impressed my new terminal app.
Good flow, great settings,
I came from Mate, and I want to tell everyone here to keep up the Great work Budgie.

Thank You

1 Like

(I’ve added the following to the first post)

Please use http://iso.qa.ubuntu.com/ for testing ISOs (just click the relevant links and there’s guides as you navigate the site)

Packages and hardware are meant to be tested also using QA trackers: https://wiki.ubuntu.com/QATeam/Roles/Tester

As the above page shows, probably the best way to get stuck in with testing is run Ubuntu 20.04 (either download or upgrade from 19.10 with update-manager -d ) as often as possible for usual tasks (bearing in mind that one’s productivity and data may be hampered by bugs on 20.04!) and reporting bugs with ubuntu-bug and ubuntu-bug package-name as you go.

Alternatively, there is always a huge backlog of bugs that need to be triaged (i.e., progressed towards being fixed), head to https://wiki.ubuntu.com/BugSquad for a guide on getting started with that!

1 Like

Our default iconset called Pocillo uses Moka Icons for all applications.

This has had a substantial update to catch up with GNOME 3.32/3.34 and what we know of 3.36 GNOME application icon name changes.

So look out for this and let us know of any applications that had moka based icons in 19.10 but no longer have moka icons in 20.04.

As an aside - we are looking for anyone who is interested in continuing development of moka icons

  • the upstream maintainer hasnt really done any substantial work on the icon them for a few years now.
1 Like

Hello! Friday PM update (Feb 14th, 2020) became a partial upgrade, and I don’t seem to have the new elementary menu. Everything else seems fine, I installed the application menu that comes with plank, so I have some functionality until I figure this out. Just an FYI.

  • Apparently, I just had to reset the desktop layout in the budgie theme and layout page. Hmm!

How do I help out with icons in inkscape? Tell me more…

The new layout is the default for new installs. We dont touch existing users layouts.

The upstream repo for moka is here with instructions on how to contribute

After I installed Bleachbit, I lost all other programs listed in the “System Tools”
folder in the menu. Removing Bleachbit brought them back. I tried installing and removing from both the Software library and Command Line.
Also; using Menu Editor I was greeted with “/usr/share/budgie-desktop/applications/display-im6.desktop” & “/usr/share/budgie-desktop/applications/display-im6.q16.desktop” parsing errors.

Thanks - I’ve fixed this and will be uploaded sometime this week

Sorry - I cannot reproduce - I’ve installed bleachbit (sudo apt install bleachbit) - the system tools menu and is still there - logged out and logged in to confirm also.

Ooh cool, my wallpaper :wink:

Everyone - beta 4 of budgie-extras applets were uploaded overnight (update as normal - logout and login).

This release has a mass of fixes in shuffler - notable are animation support when moving windows.

The new applications menu has had some cleanups - so just need confirmation nothing has broken here.

Lots of fixes throughout every applet to ensure /usr/bin executables are used - this ensures the applets don’t inadvertently use an exe that happens to be in your path. So we are just asking to test thoroughly all budgie-extra applets (all the applets listed here in the description https://launchpad.net/ubuntu/+source/budgie-extras)

There has been a mass of translation updates - but we are still missing lots of translations. Please help out there (https://www.transifex.com/ubuntu-budgie/ubuntu-budgie-extras)

On 19.10. Asks me to reboot after every update to budgie-extras and “Ubuntu Budgie Base”; is this expected? I just had to reboot 5 min ago

That’s the package manager; it thinks an update requires a reboot. Yes that is expected if the packager signifies the update needs a reboot.

1 Like

Latest update and I have been looking at syslog for anything I did in the panel.

3 notices. The 2nd one I tracked down to “synapse” so not Ubuntu Budgie.

  1. 40+x: budgie-panel[1703]: g_signal_emit_valist: assertion ‘signal_id > 0’ failed

  2. Once: budgie-panel[1703]: relevancy-backend-zg.vala:113: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.zeitgeist.Engine was not provided by any .service files

  3. budgie-panel.desktop[1703]: no icon

Tried to search for all of them. budgie-panel, if that is the actual origin, is on Solus(?)

Since applets live in the same process as the budgie-panel it could be an applet(s) rather than the panel itself.

To be sure you’ll have to create an empty panel - delete the old one and add the bare minimum of applets to see if you can reproduce the issue(s)

Second one - zeitgeist is an optional install for the new applications menu - so if you don’t care too much about zeitgeist being used to track your application launches, install the zeitgeist package.

For 1 - do upgrade to get the v0.93 version of budgie-extras - that should minimise this happening.

FYI , the mailspring snap is currently broken. I continue to receive mail, but can’t write new mail. I know this is not a Budgie desktop issue and will report if possible.
The .deb@ Github has dependency problems on the development release.

Generally snap issues should be reported here https://forum.snapcraft.io/

The problem has been solved .

Hello! Saturday Feb 22, another partial upgrade this evening, rather than just an update.
@ 5.4.0-14 at this point.

–> Everything seems to have gone smoother this time, no dropped environments.
Apparently it scooped out and replaced quite a bit, but it seemed pretty seemless. Well done :slight_smile:

Everyone - I’m interested in your thoughts about “drawing” - Ubuntu Budgie never has had a painting program simply because most painting programs were either not maintained … or rather too advanced for most users (eg. gimp)

Its a rather elegant looking drawing app - think “MS Paint” … but much better.

Please have a look at v0.4.11 that is now in the focal archive.

sudo apt install drawing

@fossfreedom installing has errors.

It does start. 1st impression: looks very cool. Nice lay-out.

1 “big” issue:

1 very minor issue:

  • it probably needs a little bit more space between title and subtitle.

Screenshot from 2020-02-23 12-42-01

Got an error on closing.

Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/drawing/window.py”, line 299, in on_close
if not self.get_active_image().try_close_tab():
File “/usr/lib/python3/dist-packages/drawing/image.py”, line 215, in try_close_tab
self.selection.reset()
File “/usr/lib/python3/dist-packages/drawing/selection_manager.py”, line 123, in reset
self.image.update_actions_state()
File “/usr/lib/python3/dist-packages/drawing/image.py”, line 289, in update_actions_state
self.active_tool().update_actions_state()
File “/usr/lib/python3/dist-packages/drawing/abstract_canvas_tool.py”, line 44, in update_actions_state
self.set_action_sensitivity(‘selection_delete’, False)
File “/usr/lib/python3/dist-packages/drawing/abstract_tool.py”, line 49, in set_action_sensitivity
self.get_image().set_action_sensitivity(action_name, state)
AttributeError: ‘NoneType’ object has no attribute ‘set_action_sensitivity’

Thx. For each of these please report on the upstream issue tracker