Theme selection and remove gap in Budgie Pixel Saver applet

Currently I cannot use dark/white contrast themes with the current Budgie Pixel Saver applet, when the panel is dark/black the windows controls are not visible.
Current theme is Plata.
Also, it adds a small gap, when inactive, in the panel. I think it should have no gap like some applets, i.e. Window Preview.

themes need to support pixel-saver - so if the theme doesnt have the support you’ll get quirks like as you have described.

Pixel saver basically just places its widgets in standard ways and means - it doesnt try to style anything - styling is a theme issue not an applet thing.

Thanks. The thing is currently used themes like plata in Solus 4 and pocillo in Ubuntu should be patched to use officially supported applets.

Pocillo has been patched to be fully desktop compatible including things like pixel saver, lockscreen and slickgreeter which many themes dont do.

Latest version of Adapta theme also supports pixel saver applet.

Plata works fine if the panel is set to transparent but it becomes indistinguishable when set to solid.

How do you change transparency/opacity of a panel - without changing theme ?

Think I may have merged one too many third-party patches!

I have reverted part of the styling removal changes to the buttons so it should be themed assuming that your theme applies styling updates in this area.

Look out for the update over the next day or so and let me know if this is better (or worse).

I just upgraded to the new update. Logged in again just to be sure. Still the same. I’ve also tried other themes and they too suffer from the same issue, exception being materia theme.

Can you take some more pictures but crop to show the issues that you are referring to?

materia-compact works fine, shows appropriate window controls in according to surroundings
plata-compact is not, note window controls are barely visible but they’re there so it’s probably recognizing the panel in “light mode”
plata-noir-compact shows proper window controls
plata-lumine-compact shows proper window controls as according to surrounding panel theme
adapta-eta suffers from same issue as plata-compact
It shows the proper window control icons when forced to use either light or dark theme variant, but “neutral” version can’t recognize the version of window control for optimal contrast.

Also, this is not a *-compact theme issue. Full size versions are the same.

Isn’t it possible for the applet to force use dark variant when using “neutral” themes are in use system wide? At least adding the option to force either light or dark window controls manually if the applet/theme don’t recognize automatically.

No. Not possible to recognise a neutral theme. There is no such concept in Gtk.

Certainly possible to add a light and dark theme type checkbox.

If you or someone else comes up with light and dark .svg files for the buttons I will look to add a settings checkbox. Note. I cannot accept copies of icons. They need to be designed by hand for licensing reasons.

By neutral theme I mean the theme that is neither dark nor light variant.

Can’t you make the applet list the themes available and manually select one so as to show the buttons of choice?

I wish I could help more but I have no knowledge of Gtk or svg file building. Only of basic c++ from school. Github/Gitlab is still new to me so I have very little idea on how to set projects and help out with upstream development.

By the way, isn’t it possible for the applet to not use any space/pixel real estate on the panel while inactive? I know I’m being demanding, sorry.

Probably yes it is possible.

I will only look at resolving things as a whole not piecemeal. I need those images to begin with.

In the absence of the icons I have added a new “Theme Styling” button option for the applet in budgie-desktop-settings. This is to toggle between the gtk-theme style for buttons (which we know is highly dependent on the theme) and the default unstyled option.

Just update on 19.04 as usual to pick up the new version.

Dude, it’s perfect. Thank you so very much.