Thumbnails for videos

I do not have any thumbnails for any of my video files. I have tried several command line options I found with google. Can’t get a single one to run for me with a syntax error that I could not find. Found one GUI program that will download but won’t even start up. All I want is to have thumb nails for my video files like every other OS and/or Linux distro out there, It shouldn’t be this hard. I shouldn’t have to do it myself, it should just happen automatically.

Seems to be working just fine for me - 20.04 - downloaded an example .ogg and a .mp4 and they appeared just fine in nemo as thumbnails.

So please describe your setup - what video apps have you installed/removed since installation?

What version of UB are you using?

Is this a full install/ minimal install?

I am using Celluloid
Ver says Ubuntu Focal Fossa (development branch) but I don’t see a number. I only downloaded a few days ago.
I did a minimal install. So i expected to have to install software, and I have. I have thumbs for pics, just not video and can’t find a solution that works.

have you got the package ffmpegthumbnailer installed?

Look at the contents of /usr/share/thumbnailers/totem.thumbnailer - does it have the following entries?

[Thumbnailer Entry]
Exec=ffmpegthumbnailer -s %s -i %i -o %o -c png -f -t 10

What type of videos are you having issues with?

Yes, that entry is there. .mp4 is the issue. Which happens to account for all but 1 of my video files.

Note: I at first did a full install of UB and this was not a problem. But there was just too much stuff I didn’t need that came installed. So, I did a minimal install and well… it isn’t going so smooth. I was going to atatch that file but I can’t it isn’t an “approved” file type. Really, I am just frustrated and ready to go back to ElementaryOS, There are a lot of things in UB I love, but it feels like death from a 1000 paper cuts. If there is a quick easy way to fix this than fine. If I have to go back to a full install with all that stuff, then UB is probably not for me.

You do understand you are testing a pre beta release? This is valuable feedback.

However it really does sound that you aren’t prepared to work through issues and help resolve pre beta software quirks which is most unfortunate.

  1. Actually no, I didn’t realize that a pre beta (aka Alpha) is what I had gotten a hold of.
  2. As I have spent the last 20+ years as a Software Analyst, writing test cases, test scripts and automated tests all day every day. I really do not want to do software testing after I get home from work.

If you have no further suggestions for a solution. I will go back to ElementaryOS until this version of UB is at least a Release Candidate.

Also, if I may suggest. Almost every company I have worked for has had some kind of visual indication for a non release product. Maybe consider putting the word “Beta” on the boot screen or something. A clear visual distinction between a release and a non release is a nice thing.


Not meant offensive, but how clear would you like to have it:


I can imagine the blind spot you were having, but projecting it to anyone else isn’t usually the productive thing to do.

I am very encouraged to see your experience. Its very valuable.

Thus you should be very aware when reporting to produce a repeatable test case to allow analysis, diagnosis and resolution. This is unfortunately missing with this thread.

From the limited information you have given I have:

  1. Used the latest 20.04 daily
  2. installed a minimal install
  3. install celluloid
  4. Downloaded an example mp4 from
  5. Opened Nemo and navigated to the Downloaded folder - the thumbnail of the video was visible.

Since there is no further information about what you have done there isn’t much more that I can advise what you have installed/configured. If the sample video I pointed to you works for you then I can only assume its the mp4 file you have that is causing the issue - perhaps how its encoded.

As such things are working as expected out of the box.

All I was saying it is a common practice that is all. For example, and not naming the company I work for. We do web apps for insurance. Our test site literately has dancing bananas in the top corner. Just a visual queue to remind the person that they are in the test site. I don’t remember wich distro but one puts a default wallpaper with the word 'Beta" Your post is patronizing and seems to try to say that no one else does what I suggested. I have way to many years of experience otherwise. I didn’t suggest that you somehow had to, nor did I blame UB for me downloading the beta and then thinking it was a release.

I am not sure what is going on either. I downloaded the sample video and still don’t have a thumbnail. But, I will put my UB journey on pause while this new version is finished baking. I will be back on day one of the new release and give it an other go.

@DFergFLA I don’t know if that helps, but the official Ubuntu release is 19.10. If you are using 20.04, it is a pre-release version that still might require some refinements. You might have downloaded the 20.04 version mistakenly (happened to me as well, so I agree with you that there could be a louder warning sign) … .

You can check the official Ubuntu base version here at the Ubuntu site. The latest version is 19.10.

Have you tried with Ubuntu Budgie 19.10?

I am using Ubuntu Budgie 19.10 for production and look at my screenshot from Nautilus: at least on my notebook the video thumbnails are all there …

Ok so here is a question or at least maybe a clue for a developer. I spent the last few hours playing around. I tried putting one file at a time into the video folder after I deleted the files inside .cache\thumbnails, then rebooted. I added one file. For a second or two I got the default square thing that shows up right after you copy a file as the system generates the thumbnail… then only got the default icon. I played around some more and right before I was going to erase UB I downloaded Dolphin File Manager. Right after I opened it, all my missing video thumbnails generated and can be viewed from either FM. If I add new video files a thumbnails gets generated. If I uninstall Dolphin any existing thumbnails remain, but new video files do not get thumbnails. I don’t even have to open Dolphin for thumbnails to be generated. I only have to have it installed. Without it, I don’t get video thumbnails at all. I do not know if it is specific to Dolphin, that is the only 3rd party FM I have tried. But after playing around like this for the last few hours. I can recreate this at will. Also, the default FM will not auto refresh to show me new thumbs after they are generated. I have to exit the folder and go back to it. If I am in Dolphin I can see the thumbs getting generated right in the Dolphin FM.