UB hangs after logout/login

This happens on two different laptops running 22.04.2
Select logout from raven menu

At the login prompt, enter password and then system hangs

journaltcl red entries:

Jun 14 06:35:36 rob-T510 systemd-udevd[307]: /etc/udev/rules.d/60-brother-libsane-type1-inst.rules:14 Invalid key ‘SYSFS’

Jun 14 06:35:46 rob-T510 systemd[1]: Failed to start Process error reports when automatic reporting is enabled.

Jun 14 06:35:54 rob-T510 lightdm[1061]: gkr-pam: unable to locate daemon control file

Jun 14 06:36:13 rob-T510 pulseaudio[1121]: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service ‘org.bluez’: t>

Jun 14 06:36:14 rob-T510 sudo[1929]: rob : TTY=pts/0 ; PWD=/home/rob ; USER=root ; COMMAND=/usr/bin/journalctl -ae --full
Jun 14 06

Additional testing:
I have a third system, running same OS and revision level. It’s is a laptop. The logout/in does not fail on this system.
The two laptops that do fail have LUKS encryption for the /home partition.
The one laptop that works correctly uses Encryptfs for the /home partition.
All three laptops use NFS to mount a NAS device with the same fstab entry.
If I remove the NSF mount from a laptop that fails the logout/in works correctly.

Interesting observation with NFS mounts

This Q&A infers adding “soft” to the fstab entry should prevent the NFS remount on log in from hanging

This gets spookier by the minute.
I added soft to the fstab nsf mount.
I then reboot the system.
Once logged in i select the Logout from the raven menu.
I enter the password into the lightdm prompt and the system never logs in, it just sits there.
Now the spooky part.
I do ctl-alt f2 and drop into terminal mode.
I log in successfully and then the GUI pop up.
OK, so then I do the logout/in sequence again and now it works. /NAS/nfs-xxx nfs defaults,soft,nfsvers=3,noatime,x-gvfs-show,x-systemd.automount 0 2

hmm - check who the mount is created for (ls -la mountlocation)- should be you as the user - if its root then that probably an issue where the user on login is trying to touch the mount created as root

I spun up a clean 22.04.2 install with virtualbox. I added a nfs mount and the raven logout/in worked fine. I repeated the install using full disk LUKS. Again, everything worked as expected. So, either the partual LUKS incryption of the home partition is causing the problem or something else. My sense says that the raven logout is missing something but I have no idea on how to diagnose.