Updated to 19.10 — lock screen problem

Hi there! I just upgraded from 19.04 to 19.10 and now after being in sleep, the password box does not show up anymore. I’m obligated to reboot because I’m effectively locked out. I’ve tried disabling locking the screen after sleep in the preferences, but that doesn’t work either. Some kind of GDM problem?

Any ideas as to how to fix this?

Do or did you attach a second screen? Please post the output of xrandr. I am also curious if blindly typing the password + return works.

HI! So, some updates and further information:

—blindly typing the password does not seem to work. if I click the mouse button, the cursor arrow will briefly appear but does not just on its own.

— i changed to lightdm to see what that does, but apparently that does not change anything concerning password waking from sleep? same problem.

—I sometimes use a second screen (i connect my computer to a projector sometimes to give class) but here there is no second screen, nothing is plugged in to my HDMI port.

Here’s the output from xrandr:

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
1920x1080 60.01 + 60.01 59.97 59.96 59.93 48.01*
1680x1050 59.95 59.88
1600x1024 60.17
1400x1050 59.98
1600x900 59.99 59.94 59.95 59.82
1280x1024 60.02
1440x900 59.89
1400x900 59.96 59.88
1280x960 60.00
1440x810 60.00 59.97
1368x768 59.88 59.85
1360x768 59.80 59.96
1280x800 59.99 59.97 59.81 59.91
1152x864 60.00
1280x720 60.00 59.99 59.86 59.74
1024x768 60.04 60.00
960x720 60.00
928x696 60.05
896x672 60.01
1024x576 59.95 59.96 59.90 59.82
960x600 59.93 60.00
960x540 59.96 59.99 59.63 59.82
800x600 60.00 60.32 56.25
840x525 60.01 59.88
864x486 59.92 59.57
800x512 60.17
700x525 59.98
800x450 59.95 59.82
640x512 60.02
720x450 59.89
700x450 59.96 59.88
640x480 60.00 59.94
720x405 59.51 58.99
684x384 59.88 59.85
680x384 59.80 59.96
640x400 59.88 59.98
576x432 60.06
640x360 59.86 59.83 59.84 59.32
512x384 60.00
512x288 60.00 59.92
480x270 59.63 59.82
400x300 60.32 56.34
432x243 59.92 59.57
320x240 60.05
360x202 59.51 59.13
320x180 59.84 59.32
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)

Ah, my suspicion to an off-screen lock-screen box is wrong. Only thing I can think of is a corrupted dconf database. To check, could you rename the folder ~/.config/dconf, immediately log out and back in? You will lose all (g) settings, but if lock-screen works, you know the cause.

To undo, rename the renamed dconf folder (back), and log out/in again.

Unfortunately, no luck there either…

I think this is upstream issue, I run Solus and I have this problem too since three weeks I think. At this time Solus updated to Gnome 3.34.
@chen, don’t reboot just go to another tty Alt+Ctrl+(F1, F2, ..., or F6), log in and then run this command:
sudo systemctl restart lightdm.

I haven’t found a solution for it, so for now i disabled everything, sleed and suspend.

1 Like

If we think this is a upstream issue please (from ubuntu) can you report it to launchpad via

ubuntu-bug lightdm

This is so that the lightdm maintainer is made aware - suggest make clear this has occurred since GNOME 3.34 and affects Solus as well.


Reported here.

Hmm - you didnt run ubuntu-bug lightdm so it didnt attach any logs to help diagnosis.

Please run apport-collect 1850122 to attach the logs for your machine.