Very slow lock screen login

I have a issue with the lock screen.
Aften sleep mode, it wakes up quite quick, but the password window is dead. it is not possible to write inn the password. So after waiting a couple of minutes, the screens goes black and opens up again. Then with a working active window for password input.
Not a biggie, but it slows down the process to start up the work after a coffee break.

I am using the new 21.04 version so could be a bug that are known and on the list.

It’s still very early days for 21.04 with many components that could be part of this issue.

So please monitor and upgrade as usual. Around mid March I would expect all the key changes to be in and then bug fixes will be used to stabilise the software in the repositories.

Yes, I suspect it will settle up after a while.

I have another issue after I connected my screen #2.
The nice desktop clock is gone. Can not find the setting to have it back.

Please can we have one issue per thread. Thx

Also getting the same problem on a new HP laptop, standard Ubuntu 20.04 installation.

Very slow lock screen login. Just like the original poster.

VERSION=“20.04.2 LTS (Focal Fossa)”
PRETTY_NAME=“Ubuntu 20.04.2 LTS”

Run in a terminal:

journalctl -ae --full

Scroll back to around the time-stamp you saw the lock screen first appeared. What do you see between that timestamp and when you see the lock screen password box?

Hopefully you will see what is contributing to the slow startup.

There are around 200 lines of output during that time window. The lock screen and password box appear quickly. They are responsive to the mouse, but not the keyboard. The keyboard device is “removed”, as shown below. “device removed”. It reconnects 15 seconds later.

Aug 17 08:47:53 HP-Pavilion-Laptop-2 NetworkManager[704]: <info>  [1629208073.8286] sup-iface[0x560f46774a10,wlp0s20f3]: supports 5 scan SSIDs
Aug 17 08:47:53 HP-Pavilion-Laptop-2 NetworkManager[704]: <info>  [1629208073.8298] device (wlp0s20f3): supplicant interface state: starting -> ready
Aug 17 08:47:53 HP-Pavilion-Laptop-2 NetworkManager[704]: <info>  [1629208073.8299] device (p2p-dev-wlp0s20f3): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
Aug 17 08:47:53 HP-Pavilion-Laptop-2 NetworkManager[704]: <info>  [1629208073.8304] device (wlp0s20f3): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
Aug 17 08:47:53 HP-Pavilion-Laptop-2 acpid[689]: input device has been disconnected, fd 16
Aug 17 08:47:53 HP-Pavilion-Laptop-2 /usr/lib/gdm3/gdm-x-session[1477]: (II) config/udev: removing device AT Translated Set 2 keyboard
Aug 17 08:47:53 HP-Pavilion-Laptop-2 /usr/lib/gdm3/gdm-x-session[1477]: (**) Option "fd" "34"
Aug 17 08:47:53 HP-Pavilion-Laptop-2 /usr/lib/gdm3/gdm-x-session[1477]: (II) event14 - AT Translated Set 2 keyboard: device removed
Aug 17 08:47:53 HP-Pavilion-Laptop-2 /usr/lib/gdm3/gdm-x-session[1477]: (II) UnloadModule: "libinput"
Aug 17 08:47:53 HP-Pavilion-Laptop-2 /usr/lib/gdm3/gdm-x-session[1477]: (II) systemd-logind: releasing fd for 13:78
Aug 17 08:47:56 HP-Pavilion-Laptop-2 ModemManager[800]: <info>  Couldn't check support for device '/sys/devices/pci0000:00/0000:00:14.3': not supported by any plugin

You are using GDM3? i.e. the login manager that comes with GNOME-Shell?

That will not work very will with anything other than GNOME-Shell - it breaks even more desktop environments in 21.10.

We recommend using anything EXCEPT GDM3 - the default for Ubuntu Budgie is Slick Greeter & LightDM

This is a standard Ubuntu 20.04 installation. Not customized. Also, not Budgie. I posted because the thread did seem close to what I was experiencing…

If GDM3 isn’t recommended, then why did the Ubuntu installer give me GDM3?
If I change it, will the entire desktop be completely different? Is there a link to fix only this GDM3 setting?

Ah. Well in this case, this thread and forum is specific to the budgie desktop running on either debian or ubuntu.

Your issues are different (probably). Best forums for gnome-shell are and/or