[20.04] hot corners do not work

I’m new on budgie, it’s been 3 weeks since I installed it and it’s really good, congratulations.
However I have a problem with the hot corners. I installed the applet well. But none of the corners I set up are working.

Thank you in advance.

The title suggests you’re on UB 20.04, right? A few things:

  • What command or task are you making hotcorners run?
  • Are you setting up from Budgie Settings or from a panel icon?
  • What happens if you open a terminal and run: budgie-panel --replace& (keep terminal window open, see what it spits out), then add the hotcorners applet and use corners?

Yes indeed I am of course ubuntu budgie 20.04.

  • I tried to launch different commands proposed “show desktop”, “All window in Grid” etc…
  • I don’t see where in Budgie Settings you can set the hots corners I used an applet in the menu bar.

result of the requested command while I set a hotspot in the applet:

   [1] 7046
➜  ~ ** Message: 18:01:33.941: manager.vala:1460: Replaced existing budgie-panel

[2]  - 5169 done       budgie-panel --replace
➜  ~ INFO:root:start
INFO:root:Menu shown
INFO:root:Fetcher started

(budgie-panel:7046): Indicator-Applet-WARNING **: 18:01:34.316: unable to open indicator service file directory: Erreur à l’ouverture du répertoire « /usr/share/unity/indicators » : Aucun     fichier ou dossier de ce type
sys:1: Warning: g_file_test: assertion 'filename != NULL' failed
sys:1: Warning: ../../../gobject/gsignal.c:1763: parameter 1 of type 'SynapseResultSet' for signal "SynapseDataSink::search-done" is not a value type

** (budgie-panel:7046): CRITICAL **: 18:01:34.409: Client.vala:88: Initializing client failed
** Message: 18:01:34.444: libsession.vala:50: DESKTOP_AUTOSTART_ID not set, session registration may be broken (not running budgie-desktop?)
** Message: 18:01:34.455: DBusService.vala:64: Service registration succeeded

** (budgie-panel:7046): WARNING **: 18:01:34.473: relevancy-backend-zg.vala:56: Unable to check Zeitgeist data sources: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name     org.gnome.zeitgeist.Engine was not provided by any .service files

** (budgie-panel:7046): WARNING **: 18:01:34.546: relevancy-backend-zg.vala:113: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.zeitgeist.Engine was not provided     by any .service files

** (budgie-panel:7046): WARNING **: 18:01:34.546: relevancy-backend-zg.vala:197: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.zeitgeist.Engine was not provided     by any .service files

(budgie-panel:7046): LIBDBUSMENU-GLIB-WARNING **: 18:01:35.740: Getting layout failed: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: An AppArmor policy prevents this sender from sending this message to this recipient; type="method_call", sender=":1.147" (uid=1000 pid=7046 comm="budgie-panel --replace " label="unconfined") interface="com.canonical.dbusmenu" member="GetLayout" error name="(unset)" requested_reply="0" destination=":1.121" (uid=1000 pid=2406 comm="/snap/chromium/1411/usr/lib/chromium-browser/chrom" label="snap.chromium.chromium (enforce)")

what does your hotcorners values look like?

Here is mine:

I obviously don’t have the same visual as you.

Ah indeed. Please can you take a screenshot of the panel applet popup.

Just a hunch: do you by any chance use fractional scaling?
Scaling in hotcorners is of type int, so that would explain having issues.

I don’t see this setting active.

Hmm… I dont see any obvious reason why things aren’t working.

When you are moving your cursor into a corner are you doing this fairly fast or really slowly?

I tried slowly and quickly but without any result.

And to double check, in Previews Control and Shuffler Control, you have those activated options ticked?

Without those ticked those hotcorner options will not work.


I’m having the same problem though mine seem to work rarely, not never.

I have some new info to bring to this post. Indeed today in a concern to save the battery of my laptop, in nvidia-settings I selected “power saving” mode which disables the graphics card of nvidia for the one of intel. Well there, the hot corners work. But I still don’t have the correct display in the applet.

That’s a very interesting observation about nvidia.

What do you mean by the ‘correct display’?

In the hotcorner applet control panel.

I still dont understand. That is the correct display for 20.04.

Only in 20.10 or if you are using our daily extras ppa will you see lots of configuration options in budgie desktop settings

Sorry, I didn’t understand that the screenshot you shared on November 20th in this topic didn’t match the version of the OS I’m using.

I switched from Intel Graphics to Nvidia - things are still working here on 20.04.

Just to check - if you move the pressure value from 50 to zero then does things work for you?

i.e. with 50 pressure value you need to move your mouse fairly fast to activate the hotcorner. With zero pressure the hotcorner should just activate instantly.