23.04 --> 23.10 Upgrade

I am attempting to do this upgrade and it has been a major challenge. I have used “sudo apt upgrade” to upgrade over 1000 packages, and the Budgie control center now shows I am running 23.10 and Budgie 10.7.1 (not 10.8.2).

But if I attempt to execute “sudo apt dist-upgrade” I get an immediate error: “The following packages have unmet dependencies:
gnome-remote-desktop : Depends: libmutter-12-0 (>= 44~) but it is not going to be installed
E: Broken packages”
I tried to install the libmutter dependency, it failed.

I also get this error when trying to add the Budgie ppa: “E: The repository ‘Index of /ubuntubudgie/backports-budgie/ubuntu mantic Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.”

The Software Updater tells me I can do a partial upgrade, but then it fails with error: “Could not calculate the upgrade. An unresolvable problem occurred while calculating the upgrade. This is most likely a transient problem, please try again later.”

This has been going on for several days. Is a clean install required to get 23.10 and 10.8.2 installed properly? What am I missing? Thx.

I strongly suspect you have one or more PPAs installed that are interfering.

That PPA you pointed to is specifically for 22.04 - you shouldn’t use it for 22.10/23.04 or 23.10

Generally advice for uplifting from any release is to ppa-purge any PPAs first BEFORE you attempt an upgrade.

1 Like

Thx fossfreedom. I did do a ppa purge prior to installing. But I thought 23.10 was Mantic? If not, can you point me to the correct one?

There is no PPA specific to mantic. Mantic has v10.8 which is the stable version the UB team recommends.

v10.8.2 is in the next development version 24.04. Either this or v10.9 will form the next release of budgie for the LTS release.

1 Like

Well, this has devolved into a bit of a mess. 23.10 is now installed, but when I attempt to login I get “Failed to start session”.

@fossfreedom, if there is no PPA specific to mantic, what does the clean install Ubuntu Budgie 23.10 use for updates? I’m a bit confused on this.

I’m considering just removing Budgie and going back to the gnome desktop.

Just the regular ubuntu repositories.

Please explain what your start point is for the upgrade. 23.04?

How are you doing the upgrade … step by step.

Before the upgrade your need to check that the UB meta package is still installed. If it was uninstalled mistakenly then the upgrade will only partially complete.

sudo apt install ubuntu-budgie-desktop

Are you using gdm3 or lightdm for your login manager? GDM3 only works for gnome-shell. It breaks budgie.

1 Like

Start point was Ubuntu 23.04 and Budgie 10.7.1

Upgrade steps:

  1. First tried the Software Updater, it failed with Unresolved error, could not calculate upgrade.
  2. Purged PPas
  3. went to command line and tried “sudo apt update” then “sudo apt dist-upgrade”, which failed similar to Software Updater
  4. Identified broken packages and removed, tried again via CL. “sudo apt upgrade” was able to upgrade many packages. I have been able to get Ubuntu 23.10 installed, but upon reboot have the “Failed to start session” error.

I will check on the UB meta package. Since I am unfamiliar with it, likely I have not messed with it purposely. Have to be using lightdm, otherwise Budgie 23.04 would not have run smoothly for extended periods.

Thanks for your continued assistance.

apt-cache policy budgie-desktop yields: Installed: (none) Candidate: 10.8-2ubuntu3.

So it looks like the UB meta package is there, and I have upgraded from 10.7.1 to 10.8.

Executing “systemctl status display-manager” shows that lightdm is running. However, in the output I get “seat type xlocal is deprecated, use type=local instead”. I will look at modifying this in the lightdm config file. Also see “gkr-pam: couldn’t unlock the login keyring” and “gkr-pam: unable to locate daemon control file”. Unsure what to do with these last two.

Edit: reset the gnome keyring, but that did not help.

The “Failed to start session” was giving me fits. I went to command line with Ctrl-Alt-F1. Tried updating, upgrading, reconfiguring, reinstalling budgie desktop; nothing was working. But there was a common theme - “Unable to locate package” message.

That finally pierced the void between my ears and I re-added Main, Universe, Multiverse and Restricted repositories. Did an update/dist-upgrade, rebooted, and Viola! My budgie desktop is back, just as I left it. Thanks for your help!

1 Like