APT updates won't install

I can’t seem to figure this one out. I do ‘sudo apt update’ and it reports 3 updates available:

sudo apt list --upgradable 
Listing... Done
linux-generic/disco-updates 5.0.0.21.22 amd64 [upgradable from: 5.0.0.20.21]
linux-headers-generic/disco-updates 5.0.0.21.22 amd64 [upgradable from: 5.0.0.20.21]
linux-image-generic/disco-updates 5.0.0.21.22 amd64 [upgradable from: 5.0.0.20.21]

I then to ‘sudo apt upgrade’ and I get this:

sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Does anyone have an idea why the upgrades won’t install?

Doug

What happens if you run a dist-upgrade?

sudo apt dist-upgrade
1 Like

Same thing, nothing installs.

What is the full output of the following?

sudo apt update && sudo apt dist-upgrade
1 Like

It worked that time, strange. The only difference was that I did the update and the dist-upgrade in two separate commands. When combined it worked.

Has not dist-upgrade been deprecated in favor of full-upgrade ?

1 Like

maybe … but I’m too old and stuck in my ways!

2 Likes

I don’t blame :wink: but is dist-upgrade still an alias for full-upgrade in 19.04/19.10 ?

As far as I can gather - they do things in an identical way. Full-upgrade was introduced since it was felt dist-upgrade was a bit misleading and gives the idea that you do a distribution upgrade.

1 Like

I always update when the Program Updater notification appears.
But if I need to use the commands I don’t use dist-upgrade, I always use sudo apt upgrade.

upgrade will hold back upgrades that require other packages be removed due to dependency changes. It will only upgrade installed packages and install new packages.

dist-upgrade/full-upgrade will remove packages that were automatically installed (installed as dependencies of manually selected packages) as needed to satisfy package upgrade dependency conflicts.

First is rather conservative and cautious, second is smarter and broader.

I am confronting a similar issue of being unable to update/ upgrade a package over the last couple days.

When I run “sudo apt update && sudo apt dist-upgrade” , the output says:

  • 1 package can be upgraded. Run ‘apt list --upgradable’ to see it. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Running the latter returns:

  • usb-creator-kde/disco-updates 0.3.5ubuntu19.04.2 amd64 [upgradable from: 0.3.5ubuntu19.04.1]
    N: There are 2 additional versions. Please use the ‘-a’ switch to see them.

Running : "apt list --upgradable -a " returns :

usb-creator-kde/disco-updates 0.3.5ubuntu19.04.2 amd64 [upgradable from: 0.3.5ubuntu19.04.1]
usb-creator-kde/disco-security,now 0.3.5ubuntu19.04.1 amd64 [installed,upgradable to: 0.3.5ubuntu19.04.2]
usb-creator-kde/disco 0.3.5 amd64

But neither sudo apt update, nor sudo apt upgrade, nor sudo apt dist-upgrade nor sudo apt full-upgrade do actually update the packages. The output is always same ol’ :

  • 1 package can be upgraded. Run ‘apt list --upgradable’ to see it. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Any idea why this happens?

usb-creator-kde ? Why would you have a kde package in a Budgie setup ?

Here packages seem to mismatch a bit between channel repositories ( disco / disco-security / disco-updates ).

Nothing you can do. Just wait for maintainers tidying this up. Or let them know there may be inconsistency in repo.

Or try to force version at install :
sudo apt install usb-creator-kde=0.3.5ubuntu19.04.2

Good question: Why do I have a package usb-creator-KDE ??? I don’t have the slightest idea. Probably happened when I was trying to install a USB creator app. The package is there, the app nowhere to find.

Funny that the package even installed.

I just purged it and everything is fine.

Thanks for clarifying. A good day that starts learning something. :slight_smile: