OS Update won't update

Software & Updates show an OS Update, but when I click on either Update All or the Update button nothing happens. When I run sudo apt upgrade it tells me my system is up to date. (I’m running Ubuntu Budgie 17.10)
I would like to upgrade to 18.04.

some-else mentioned that today their notification came through. So basically just need to wait whilst your mirror catches up with the new notification package that has been released.

OK, thanks David. Just wondering why it says there’s an update, but nothing happens when

I try to update. I’ll wait it out a few more days.


Just in-case you have accidentally removed our meta package at some point in the past - reinstall the package ubuntu-budgie-desktop and update again. Maybe that is enough to kick it into life.

Tried that, it says it’s installed already. I’ll wait it out I guess. Thanks though.

What happens if you run the following?:

sudo apt update && sudo apt dist-upgrade

An alternative to force the upgrade is to switch to a TTY (CTRL+ALT+F4), login and run

sudo do-release-upgrade

Don’t do this from a graphical session because often the session will hang mid way through the upgrade as packages replacing key existing components get unpacked.

Here are the results:

eric@eric-Lenovo-YOGA-720-13IKB ~> sudo apt update; and sudo apt dist-upgrade
Hit:1 http://us.archive.ubuntu.com/ubuntu artful InRelease
Hit:2 http://archive.canonical.com/ubuntu artful InRelease
Hit:3 http://security.ubuntu.com/ubuntu artful-security InRelease
Hit:4 http://ppa.launchpad.net/fish-shell/release-2/ubuntu artful InRelease
Hit:5 http://us.archive.ubuntu.com/ubuntu artful-updates InRelease
Hit:6 https://dl.winehq.org/wine-builds/ubuntu artful InRelease
Hit:7 http://ppa.launchpad.net/seafile/seafile-client/ubuntu artful InRelease
Hit:8 http://us.archive.ubuntu.com/ubuntu artful-backports InRelease
Hit:9 http://ppa.launchpad.net/tista/adapta/ubuntu artful InRelease
Hit:10 http://ppa.launchpad.net/ubuntubudgie/backports/ubuntu artful InRelease
Ign:11 https://mega.nz/linux/MEGAsync/xUbuntu_17.10 ./ InRelease
Get:12 https://mega.nz/linux/MEGAsync/xUbuntu_17.10 ./ Release [980 B]
Fetched 980 B in 5s (188 B/s)
Reading package lists… Done
Building dependency tree
Reading state information… Done
All packages are up to date.
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages were automatically installed and are no longer required:
ccnet gir1.2-grilo-0.3 gir1.2-mediaart-2.0 gir1.2-totem-plparser-1.0
gir1.2-tracker-2.0 libccnet0 libglade2-0 libieee1284-3:i386 libqt5opengl5
libqt5qml5 libqt5quick5 libqt5webkit5 libseafile0 libsearpc1 libvlc-dev
linux-headers-4.13.0-21 linux-headers-4.13.0-21-generic
linux-headers-4.13.0-37 linux-headers-4.13.0-37-generic
linux-image-4.13.0-21-generic linux-image-4.13.0-37-generic
linux-image-extra-4.13.0-21-generic linux-image-extra-4.13.0-37-generic
linux-signed-image-4.13.0-37-generic linux-tools-4.13.0-21
linux-tools-4.13.0-21-generic linux-tools-4.13.0-37
linux-tools-4.13.0-37-generic pkg-config python-cairo python-glade2
python-gobject python-gobject-2 python-gtk2 python-searpc
Use ‘sudo apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
eric@eric-Lenovo-YOGA-720-13IKB ~> sudo do-release-upgrade
Checking for a new Ubuntu release
No new release found.

In software & updates is your “notify” option set to “Never” ? - should be “For any new version”

ok - found it - it is a known bug: https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/1768748

I think that report is saying run:

update-notifier --force-release-check

Or you may just want to subscribe to that bug report and wait until it is fixed.

I just ran

sudo do-release-upgrade

again just a few minutes ago and it’s in the process of downloading/installing the upgrade now. Thanks again for your assistance!