Cannot upgrade from 18.04 to 18.10

I tried this, ran software update, it said I was running current version but, “However, there’s an upgrade available.” I pushed upgrade and nothing happens.


Same with me, and when I run it from the terminal it says this

  • update-manager
    WARNING:root:can not import unity GI Namespace Dbus menu not available
    Checking for a new Ubuntu release
    Please install all available updates for your release before upgrading.

Nevermind, just had to run apt upgrade :slight_smile: my bad

Correct. You need to be fully up to date before the upgrade will run. I think I saw a launchpad report to that effect… can’t find it immediately though.

I was just confused because I thought update-manager would do that automatically.

think its a bug with update manager

“just had to run apt upgrade :slight_smile: my bad”

exactly what command line request is that?

sudo apt update

The above is the command to update the repository software indexes

When you run the above the next command to install new packages found by update is

sudo apt upgrade
1 Like

still doesn’t work

$ sudo apt upgrade
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

thanks 4 help by the by

Oh… but when I used the normal software updater app… there wass now an updater package…hmmm

That means there is already a silent updating process in background.

Just wait a moment. Update Manager will probably automatically appear and ask for installing downloaded updates…

…what is for you the « normal » updater app ?