Audio Issues Ubuntu 22.04.1

This started with audio not working in Vivaldi browser this morning (It was working in other apps). Until today, audio was fine, both analog and digital - I used the digital output for Christmas music the past few days. I did a search on audio issues in Vivaldi, found several solutions, tried them, nothing worked.
So then I installed pipewire using instructions on this link: Didn’t work.
I ran through some troubleshooting directions I found here: No dice.
Here is the output from “inxi -SMA”

Host: workstation Kernel: 5.15.0-56-generic x86_64 bits: 64
Desktop: Budgie 10.6.1 Distro: Ubuntu 22.04.1 LTS (Jammy Jellyfish)
Type: Desktop Mobo: ASUSTeK model: WS X299 PRO_SE v: Rev 1.xx
serial: UEFI: American Megatrends v: 3303
date: 12/09/2020
Device-1: Intel 200 Series PCH HD Audio driver: snd_hda_intel
Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel
Device-3: Logitech HD Pro Webcam C920 type: USB
driver: snd-usb-audio,uvcvideo
Sound Server-1: ALSA v: k5.15.0-56-generic running: yes
Sound Server-2: PipeWire v: 0.3.63 running: yes

System sounds still work - the Bark, Drip, Glass, Sonar. But that is it. I have tested the speakers using both analog and digital output and I get no sound from the tests. Any thoughts appreciated.

Please create another user account and login with that and retest your audio … this is to find out if your issue is system wide or localised to your current account.

1 Like

Dang…you should have warned me. :slight_smile: I logged in to the new user and fired up RhythmBox and just about blew the doors off my office. Apparently I had cranked the sound up quite a bit when I was trying to fix it under my normal user name.

I assume there is a next step here, and will be searching for the solution while waiting. Thank you, fossfreedom.

Also… obvious question … your sound volume level is ok / muted in budgie-control-center - sounds ?

Yes, sound settings have been fine, not muted. I did get sound restored in everything except Vivaldi. So it is an obvious Vivaldi issue, I will carry on with this on their forum. Sound has been a long-standing issue with Vivaldi, I suspect a recent Vivaldi update is causing the problem. Thanks again for your input!.

OK, I lied. Sound is not back to normal. I tested sound using Tuner, and it worked fine. But then I went into Sound settings and ran a speaker test. No sound. I get system sounds, but nothing from the speaker test. I tried both Line Out Analog, and Digital, nothing on both. Checking on pipewire, this is what I see:

Blockquote systemctl --user status pipewire pipewire-session-manager
● pipewire.service - PipeWire Multimedia Service
Loaded: loaded (/usr/lib/systemd/user/pipewire.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2022-12-28 06:56:42 MST; 3h 30min ago
TriggeredBy: ● pipewire.socket
Main PID: 2066 (pipewire)
Tasks: 2 (limit: 76707)
Memory: 31.8M
CPU: 8.833s
CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
└─2066 /usr/bin/pipewire

Dec 28 06:56:42 workstation systemd[2058]: Started PipeWire Multimedia Service.
Dec 28 06:56:42 workstation pipewire[2066]: mod.rt: Can’t find xdg-portal: (null)
Dec 28 06:56:42 workstation pipewire[2066]: mod.rt: found session bus but no portal

Well, this situation went to hell in a handbasket pretty rapidly. I was switching between users to compare sound configurations, did a reboot, and when it started again I got a message at login “Failed to start session”. Couldn’t find a solution online, so I did a boot repair. After the first boot repair, I could not even get to the login screen, PC would not boot. Did it again, and was able to boot by selecting the 5.15 generic kernel. But again, at the login screen, I get “Failed to start session”. I have looked online but have not found a solution.

Sounds like you have uninstalled something fundamental.

You mentioned choosing the generic kernel. Are you using someother kernel? That could be your sounds issues.

You need to switch to a TTY (ctrl alt f3), login and run

journalctl -ae --full

Scroll up using your arrow keys and look for red coloured messages. Around those will give you a hint of what is going wrong.

ctrl alt F3 does not work.
ctrl alt F1 does not work

Dropped into root maintenance from recovery mode and ran journalctl. Red messages:

EDAC skx: ECC is disabled on imc 0 (multiple)
Failed to start NVDIA Persistence Daemon
CIFS: VFS: Error connecting to socket. Aborting operation
CIFS: VFS: cifs_mount failed w/return code = -101
igb 0000:07:00.0: exceed max 2 second

Off to google the above…

Regarding the kernel, I set as my default. Grub wants me to use, but my pc will not boot with that kernel.

OK, this is just wheel-spinning at this point. Going to do a clean install and restore critical files from backup.