Bluetooth Mouse Disconnects After Short Period

I have SANWA GMAERGBT11 bluetooth mouse and it is having trouble staying connected to my Lenovo laptop using Linux (currently Ubuntu Budgie). The mouse works well with Windows but when connecting with the Linux OS’s I have tried (Mint, Ubuntu) it connects and works briefly, for a minute or two, then disconnects. In Bluetooth Settings the indicator vacillates between “Connected” and “Disconnected” at a frequency of about a 1/2 second or so - but not rhythmically: the rate is somewhat random. The mouse never works again after this. Again, the mouse works well using Windows OS on the same machine.

FWIW, I have a Microsoft Surface Arc Mouse that works perfectly in Ubuntu Budgie.

Update: Microsoft Surface Arc Mouse stopped working after about an hour. Ubuntu Budgie Bluetooth Settings show it as connected but it does not move the pointer.

I am wondering if this is a bluetooth low energy issue.

Does step 2 here help? (Disables bluetooth low energy)

Thank you @fossfreedom. I tried step 2 as suggested but it did not solve.

I searched and read yesterday that Broadcom does not suport bluetooth firmware updates. I tried the detection steps here: and saw firmware failures. I will research more and see if I can get the latest firmware loaded.

In case this is of use:

1 Like

That does very much look like the key issue … the firmware is not loading so bluez is defaulting to a mode that doesn’t really work.

Not sure of the package to file the bug report against.


ubuntu-bug linux-firmware

Or the more generic

ubuntu-bug linux

In the bug report please include that firmware message. Dont link just to this forum since the bug triagers require all bug reports to be full self contained i.e. no links to outside forums.

Thank you @fossfreedom. I appreciate your help. I am close to being a Linux newb so this is the next step for me: reporting bugs. :grin:

I tried the suggestions by @fossfreedom as well as the Broadcom firmware update on the github post. The mouse has been working for two days now with only occasional dropouts (that last for up to 15 seconds or so). I wish I had been ore methodical and tested to see which “fix” actually worked. I rebooted after each adjustment but the mouse only started working the next day after the system being off overnight. Thank you for your support.

Turns out I was wrong: again the mouse doesn’t connect. :frowning:

Since I posted the original post I have tried a bunch of Linux distros and I am now back to Ubuntu Budgie. I could not get Bluetooth working on any of the distros. (I did try Cloudready “Chrome OS” and Bluetooth worked but my machine was bogged down with some kind of bloat so it was unusable.)

FWIW this is a different laptop - should I start a new thread?

I have also tried many of the command based fixes offered on various forums but to no avail. All failed. I even started a thread here but I am starting a new thread to avoid confusion (mostly my confusion).

I got some information using a dmesg command but I really don’t know what else to share. It says ACL packet - whatever that is. I have a Broadcom BCM20702A0 Bluetooth device in a Dell E6430.

Here is what I got:

mchipeur@dell:~$ sudo dmesg | grep -i bluetooth
[sudo] password for mchipeur: 
[   18.325101] Bluetooth: Core ver 2.22
[   18.325120] Bluetooth: HCI device and connection manager initialized
[   18.325124] Bluetooth: HCI socket layer initialized
[   18.325125] Bluetooth: L2CAP socket layer initialized
[   18.325129] Bluetooth: SCO socket layer initialized
[   36.030471] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   36.030474] Bluetooth: BNEP filters: protocol multicast
[   36.030481] Bluetooth: BNEP socket layer initialized
[   58.586448] Bluetooth: RFCOMM TTY layer initialized
[   58.586458] Bluetooth: RFCOMM socket layer initialized
[   58.586466] Bluetooth: RFCOMM ver 1.11
[  131.914153] Bluetooth: hci0: corrupted ACL packet
[  131.914190] Bluetooth: hci0: ACL packet for unknown connection handle 12
[  157.388570] Bluetooth: hci0: corrupted ACL packet

This thread has the same reported corrupt messages

Basically it says some devices autosuspend themselves and have difficulty reestablishing a connection again

1 Like

Thank you @fossfreedom. I will try the instructions on the link.

I have a Microsoft Sculp Touch mouse, pretty old. I was surprised it paired easily and works perfectly, also after the laptop was suspended.
But this is with a HP 430 G6 (i5 8th gen) laptop.

On a brand new (released last month) HP Envy x360 13-ay0003nd laptop with AMD Ryzen 4700U I couldn’t get it to work. After pairing it always says “disconnected”. But honestly more stuff doesn’t work yet with Ubuntu like suspend, brightness etc. Support is a bit better with newer kernels.

My conclusion: Bluetooth mice work with UB fine as long as the laptop Bluetooth hardware is fully supported by Ubuntu.