Wifi suddenly disconnect

I hadn’t been using this slim laptop for a while, i turned it on and updated once budgie 10-14 days ago (just updated and turn off after few mins) .

when I tried to get some work done on it this afternoon, i received a 3.x MB update, then wifi started disconnecting within 10-15 mins. I have to reboot in order to get wifi back.

This laptop is using an intel AC 3165 wireless adaptor, i had exactly the SAME issue with windows 10 update last year, it’s driver’s problem. I had never encountered this issue in 19.04 budgie before.

What can I do? I don’t want to spend time re-installing everything again.
I am using win 10 to type this message now, no disconnection at all.

please kindly advice.

thank you very much.

What was updated?

If it was a kernel update then boot with the older kernel via grub (press shift immediately after the computer starts or press Escape)

1 Like

I have no idea whether or not kernal has been updated or not… usually i just press update…
it was running on 5.0.0.15, now trying older kernal 5.0.0.13, it seems working fine now…

thanks a lot

1 Like

I i thought it works but wifi disconnected again,have to reboot to get wifi back.
it worked perfectly before, I haven’t install any new software recently, i don’t know what causes this issue.

Please file a bug report:

ubuntu-bug linux

Additionally - you should be able to restart your wifi without rebooting:

sudo systemctl restart NetworkManager

(https://askubuntu.com/questions/271387/how-to-restart-wifi-connection)

no, i’ve tried this command, it doesn’t work!
nothing shows up in wifi/visible network, gotta reboot in order to restart wifi adaptor.
This is the typical symptom of that driver issue. I have no idea when the driver has been modified or updated… I received one budgie update today but i doubt it causes this issue.
was it because I updated once or twice via synaptic package manager? maybe I should only use the built in manager for future update.

Doubtful it has anything to-do with synaptic vs update-manager.

I am intrigued that this happened with Windows as well as linux. Two different operating systems.

It could also indicate a failing hardware component as well.

In the linux world - wifi drivers are typically part of the linux kernel - unless it hasnt been merged in the kernel it is generally available as a dkms module.

Yours is an intel and should be part of the kernel. Given that you tried a slightly earlier kernel and it still occurs would indicate more hardware than software.

I would test out an 18.04.2 live ISO - boot into the live session and leave it running for a while. If it doesn’t disconnect - then it points to a software issue with the kernel (typically) - or possibly a Network Manager issue. 18.04 uses kernel 4.18 and an older network manager. If it disconnects, then would strongly suspect a hardware issue.

Note - it could be a hardware issue with your wifi router as well where the computer is not restablishing a disconnection.

it’s perfectly fine in Windows 10 now, there is something wrong with 2018 Oct update, all I have to do was let windows choose the best driver automatically and it’s fine now!

I have no idea why i happened to my budgie this afternoon, it happened again 2 hours ago。 worse case I reinstall everything. It was working perfectly fine before.

thank you for your help

1 Like

Maybe if you update to the latest kernel (5.1.15 I guess) the problem will be solved. But I am no sure if this is reocommended

I reinstalling budgie now. It keeps all previously installed apps and clear the system at the same time, hopefully the problem can be resolved.

hardware wise, i think the wifi adaptor is working fine because I have been using it for couple of hours in win 10 and I have had no problem at all.

thank you for your advise, i will give 5.1.15 kernal a shot before I erase EVERYTHING, this is the last option…

1 Like

Yeah, because the lastest kernel has some upgrades at hardware compatibility. So, maybe it can work for you!

For some unknown reason, re-installation failed… lost all installed programs after reboot… had to do a fresh installation again… Kernal is still 5.0.0.15, it is the latest in update now, probably i have to find 5.1.15 somewhere else if I need it.

Anyway, wifi seems ok at home now, will further test it today’s afternoon at the very same starbucks where wifi constantly disconnected.

thanks for your advice.

1 Like

Weird and sad.

I hope that your WIfi works great now

Anyway, if the bug persists, try to reset the bios. Once my laptop became super slow and I didin’t know why. Then I reseted the bios and the speed backed to its normal.

After some time, I found an answer for it: I accidentally pressed FN + F2, which limits the CPU to the half of the potency. Reseting the bios backed it to the normal, but I could solve it just by pressing FN + F2 again (If I knew this haha)

since windows 10 has no such problem, it is safe to assume that the wifi adaptor is working properly.
I reset bios and re-installed budgie once more (messed it up with autoremove before), need to test it further to ensure the problem has been resolved or not…

thanks for your advise!

1 Like

…is supported by linux kernel since 4.2 ( by iwlwifi module https://www.intel.com/content/www/us/en/support/articles/000005511/network-and-i-o/wireless-networking.html )

You should check if linux-firmware package is installed on your system, it’s where to find iwlwifi-7265 ( = Intel® Dual Band Wireless-AC 3165, same firmware as the 7265 ).

thanks for your reply.

I checked out this intel wireless driver for linux before but I didn’t know how to install it, i am new to linux.
many example said extract the content to lib/firmware and then work on it… well… i was stuck…

anyway, I reinstalled everything and my budgie is back to normal…

i updated kernal last night from 5.0.0.15 to 5.0.0.16, everything seems back o normal now.
I have been using this laptop for over 2 hours in startbucks now.