Boot Error No Such Partition

I have installed Budgie 18.10 on my Dell Laptop yesterday. Everything is working smoothly, with the exception that I am getting the following error message on boot:

 Error: No such partition
 Entering rescue mode
 Grub rescue

I can start my computer by hitting F12 and choosing UBUNTU, but I wonder if there is a simple way to reconfigure the Grub menu, without too much hassle.

There are instructions like the one here, but I’m afraid to make things worse.

Before, I had a double boot with Windows and chose to Delete Everything on my hard drive. Seems there are some leftovers from Windows in the BIOS.

Sounds like an efi issue. Your laptop cannot find the default efi boot file by itself and you have to help it by choosing the efi entry via f12.

The resolution is dependent upon your laptop efi settings

E.g. does any of this help?

Did not work, actually. The options described in the post are not in my boot setting, so I’d rather press F12, before I mess up my system, :slightly_smiling_face::slightly_smiling_face::slightly_smiling_face:

No big deal, anyway … last time, the grub menu was adjusted during a normal Ubuntu update process. So, I guess I just wait. Doesn’t diminish the experience and pleasure to use Ubuntu Budgie.

Thanks for finding the time to answer my post.

Interesting. Try running

sudo update-grub

To force a grub update.

Tried it, but unfortunately no alteration …no big deal, though …

I add a similar issue. after installing ubuntu-budgie, my SSD disk containing the system install had become invisible to my computer (including in the BIOS).
I just unplugged and replugged the SATA wires of all my disks (SSD or not) and my SSD was newly visible so my computer was able to boot.

Just for information I had this issue each time I tried to install ubuntu-budgie on my desktop-computer (18.04 and 18.10) whereas I never experimented it with ubuntu or xubuntu since 2008.
That lost of the disk detection seemed to be a particularity of my machine, because I never saw it in virtual machines.

Found a simple fix: just changed the boot options from LEGACY to UEFI …

1 Like