Budgie 19.10. Keyboard set to UK but stays on USA setting

When typing the pound sign I get a #, when I type the hash I get | and when typing the @ sign I get " and vice versa.
I have rechecked languages, keyboard setup etc. and all looks fine?

Do make sure language/formats/input source/regional formats are all set to UK values as per the picture above.


Thank you for your reply.

I have carried out all of the required settings.

I am a long time user of Linux and currently run two varieties at all times. I don’t have this issue with any other distro.

I’m a UK user … no issues here so something very weird with your setup.

Suggest swap all your settings to US - logout/login and then swap back to UK.

Also worth checking your keyboard indicator applet is set to UK not US (Panel applets); possibly something odd with your ibus setup since that is what the applet controls.

Hi David

I checked the panel applet and it was set to UK, however I also changed the settings to US, logged out/in and then set the language back to UK and IT’S WORKED!

Thank you very much.