Budgie welcome unable to install apps

Whenever I try to install anything from Budgie welcome, it always fails. At first, I thought that it was because I had the installed the Budgie desktop on what was Ubuntu Mate, so I installed Ubuntu Budgie 18.04.4, since performing a clean installation isn’t a big deal for me on this computer. After installing Ubuntu and downloading updates, it still wouldn’t work.

Hi

What is the output you see in the terminal of

sudo apt update && sudo apt dist-upgrade

Get:1 [link removed] bionic-security InRelease [88.7 kB]
Hit:2 [link removed] InRelease
Hit:3 [link removed] InRelease
Get:4 [link removed] InRelease [88.7 kB]
Hit:5 [link removed] bionic InRelease
Get:6 [link removed] InRelease [74.6 kB]
Hit:7 [link removed] InRelease
Fetched 252 kB in 2s (139 kB/s)
Reading package lists… Done
Building dependency tree
Reading state information… Done
3 packages can be upgraded. Run ‘apt list --upgradable’ to see them.
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages were automatically installed and are no longer required:
apturl apturl-common argyll argyll-ref dvd+rw-tools efibootmgr evince-common folks-common fonts-liberation2 fonts-opensymbol gedit-common gir1.2-champlain-0.12 gir1.2-clutter-1.0 gir1.2-clutter-gst-3.0 gir1.2-cogl-1.0 gir1.2-coglpango-1.0 gir1.2-evince-3.0 gir1.2-gdesktopenums-3.0 gir1.2-geoclue-2.0 gir1.2-geocodeglib-1.0 gir1.2-gfbgraph-0.2 gir1.2-gnomedesktop-3.0 gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-gtkchamplain-0.12 gir1.2-gtkclutter-1.0 gir1.2-gtksource-3.0 gir1.2-gweather-3.0 gir1.2-json-1.0 gir1.2-peas-1.0 gir1.2-rest-0.7 gjs growisofs gstreamer1.0-gtk3 gthumb-data guile-2.0-libs libatkmm-1.6-1v5 libbdplus0 libboost-date-time1.65.1 libboost-filesystem1.65.1 libboost-iostreams1.65.1 libboost-locale1.65.1 libbrlapi0.6 libburn4 libcairomm-1.0-1v5 libchamplain-0.12-0 libchamplain-gtk-0.12-0 libclucene-contribs1v5 libclucene-core1v5 libcmis-0.5-5v5 libcolamd2 libdvdnav4 libdvdread4 libeot0 libevdocument3-4 libevent-2.1-6 libevview3-3 libexiv2-14 libfolks-eds25 libfolks25 libfwup1 libgail18 libgc1c2 libgfbgraph-0.2-0 libgjs0g libglibmm-2.4-1v5 libgmime-2.6-0 libgnome-games-support-1-3 libgnome-games-support-common libgpgmepp6 libgpod-common libgpod4 libgtkmm-3.0-1v5 libgtksourceview-3.0-1 libgtksourceview-3.0-common libgxps2 libisofs6 libjte1 libkpathsea6 liblirc-client0 liblua5.2-0 libmozjs-52-0 libmpeg2-4 libmpv1 libmusicbrainz5-2 libmusicbrainz5cc2v5 libneon27-gnutls libopencore-amrnb0 libopencore-amrwb0 libpangomm-1.4-1v5 libperl4-corelibs-perl libpkcs11-helper1 libpoppler-glib8 libqqwing2v5 libqt5positioning5 libqt5printsupport5 libqt5qml5 libqt5quick5 libqt5sensors5 libqt5webchannel5 libqt5webkit5 libraw16 libsgutils2-2 libsidplay1v5 libsigc+±2.0-0v5 libspectre1 libsuitesparseconfig5 libuchardet0 libva-wayland2 libxmlsec1 libxmlsec1-nss libyelp0 lp-solve media-player-info network-manager-openvpn openvpn phantomjs python3-brlapi python3-ewmh python3-louis python3-mako python3-markupsafe python3-pyatspi python3-pyxattr python3-speechd python3-xdg python3-xlib rtmpdump xbrlapi xprintidle youtube-dl
Use ‘sudo apt autoremove’ to remove them.
The following packages will be upgraded:
faba-icon-theme moka-icon-theme xserver-common
3 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 60.6 MB/60.6 MB of archives.
After this operation, 1,824 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 [link removed] amd64 faba-icon-theme all [link removed] [621 kB]
Get:2 [link removed] amd64 moka-icon-theme all [link removed] [60.0 MB]
Fetched 60.6 MB in 15s (4,047 kB/s)
(Reading database … 216976 files and directories currently installed.)
Preparing to unpack …/faba-icon-theme_4.5-a~xenial~NoobsLab.com_all.deb …
Unpacking faba-icon-theme ([link removed]) over (4.1.2-1) …
Preparing to unpack …/moka-icon-theme_5.5~xenial~NoobsLab.com_all.deb …
Unpacking moka-icon-theme ([link removed]) over (5.3.6-1) …
Preparing to unpack …/xserver-common_2%3a1.19.6-1ubuntu4.4_all.deb
Unpacking xserver-common (2:1.19.6-1ubuntu4.4) over (2:1.19.6-1ubuntu4.3) …
Setting up xserver-common (2:1.19.6-1ubuntu4.4)
Setting up faba-icon-theme ([link removed])
keep visit on [link removed]
Setting up moka-icon-theme ([link removed])
keep visit on [link removed]
man-db (2.8.3-2ubuntu0.1)
why@crap-server:~$

Thx

Run

budgie-welcome

Then install something. Anything interesting in the terminal that appears?

I get this when installing the Ant theme:
grep: /etc/apt/sources.list.d/ubuntubudgie-ubuntu-backports-bionic.list: No such file or directory
Gtk-Message: 09:58:05.626: GtkDialog mapped without a transient parent. This is discouraged.
Error executing command as another user: Not authorized

This incident has been reported.
[Apt] Reloading cache…
[Apt] Cache reloaded.

I also get a pop-up that tells me I need the ppa:ubuntubudgie/backports repository, but it fails when I click ok. I have also tried installing the ppa itself using the option under recommendations, but it fails with the same terminal output.

So, the line

got me curious, so I tried running the program as superuser, and it worked. I think budgie welcome is trying to install apps under my account, which obviously doesn’t have the privileges required.

What type of user account have you got?

I presume you mean that you can’t use sudo with your account?

I’m using the default account that I made during installation, and I can use sudo. The only way I could install anything was by running the command “sudo budgie-welcome”

what is the version of welcome you are using ?

budgie-welcome --version

if it isnt v0.12.1 please run

snap refresh

budgie-welcome is already 0.12.1

Not really sure what is going on. I’ve done a fresh 18.04 install and refreshed to v0.12.1 of budgie-welcome.

Stuff can be installed as normal.

Weird

What is the output of this command?

id

uid=1000(why) gid=1000(why) groups=1000(why),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),119(lpadmin),128(sambashare)

hmm

sorry - I’m stumped

You should have a look at
[1⋅ Ubuntu Budgie 20.04 Testing Week |2⋅ Ubuntu Budgie 20.04 Testing Week ]
as using sudo for running a graphical app’ may have damaged some permissions in your personal folder.

You you post outputs from commands, use « preformatted text » for easier readability :