Software update error - permission unavailable and GUI will not accept password

Hello, I am very new to Budgie and have not had problems in Ubuntu nor Kubuntu like this. I am running Budgie 18.04.3.
I am running into several issues with software updating.
Running sudo apt-get update && sudo apt-get upgrade it appears nothing is available, however, the Update-manager pops up with a long list of available software. Clicking INSTALL renders a black screen with Authentication required but the password field will not accept any entry and the screen shows “authentication failed”
Then a screen with a blank box, followed by a screen that says You have stopped checking for software updates. In this box the option for settings goes no where - simply repeats the screen saying you have stopped checking for software updates.
Running sudo apt update && sudo apt upgrade yield nothing. Nor does sudo apt update && sudo apt dist-upgrade(nor full-upgrade in place of dist-upgrade)
Errors always seem to point at permission failures.
I have deleted /var/lib/apt/lists/* as per suggestions, this solves nothing
While I can continue using the OS and software, there is a constant reminder that software updates are available and then update-manager fails to work. In the terminal I find no updates available.
Looking for solutions I find similar issues but none of the solutions appear to apply.

Can I see the full terminal output of the following;

sudo apt clean
sudo apt update
sudo apt full-upgrade

karin@Budgie-Linux-HP-ProBook-650-G1:~ sudo apt clean [sudo] password for karin: karin@Budgie-Linux-HP-ProBook-650-G1:~ sudo apt update
Hit:1 bionic InRelease
Hit:2 bionic
InRelease Get:3 bionic-security InRelease
[88.7 kB] Get:4 bionic-updates InRelease
[88.7 kB] Get:5 bionic-backports
InRelease [74.6 kB]
Get:6 bionic-security/main amd64
DEP-11 Metadata [22.7 kB]
Get:7 bionic-security/main
DEP-11 48x48 Icons [10.4 kB]
Get:8 bionic-updates/main i386
Packages [572 kB]
Get:9 bionic-security/main
DEP-11 64x64 Icons [31.7 kB]
Get:10 bionic-security/universe
amd64 DEP-11 Metadata [42.1 kB]
Get:11 bionic-security/universe
DEP-11 48x48 Icons [16.4 kB]
Get:12 bionic-security/universe
DEP-11 64x64 Icons [106 kB]
Get:13 bionic-security/multiverse amd64 DEP-11 Metadata [2,464 B]
Get:14 bionic-updates/main
amd64 Packages [710 kB]
Get:15 bionic-updates/main
Translation-en [259 kB]
Get:16 bionic-updates/main
amd64 DEP-11 Metadata [282 kB]
Get:17 bionic-updates/main
DEP-11 48x48 Icons [66.6 kB]
Get:18 bionic-updates/main
DEP-11 64x64 Icons [134 kB]
Get:19 bionic-updates/universe
i386 Packages [974 kB]
Get:20 bionic-updates/universe
amd64 Packages [997 kB]
Get:21 bionic-updates/universe
Translation-en [305 kB]
Get:22 bionic-updates/universe
amd64 DEP-11 Metadata [252 kB]
Get:23 bionic-updates/universe
DEP-11 48x48 Icons [193 kB]
Get:24 bionic-updates/universe
DEP-11 64x64 Icons [433 kB]
Get:25 bionic-updates/multiverse amd64 DEP-11 Metadata [2,468 B]
Get:26 bionic-backports/universe amd64 DEP-11 Metadata [7,920 B]
Fetched 5,672 kB in 3s (2,016
kB/s) Reading package lists… Done
Building dependency tree Reading state information… Done
5 packages can be upgraded. Run ‘apt list --upgradable’ to see
karin@Budgie-Linux-HP-ProBook-650-G1:~ sudo apt list --upgradable Listing... Done gir1.2-ibus-1.0/bionic-updates 1.5.17-3ubuntu5 amd64 [upgradable ibus/bionic-updates 1.5.17-3ubuntu5 amd64 [upgradable from: 1.5.17-3ubuntu4] ibus-gtk/bionic-updates 1.5.17-3ubuntu5 amd64 [upgradable from: 1.5.17-3ubuntu4] ibus-gtk3/bionic-updates 1.5.17-3ubuntu5 amd64 [upgradable from: 1.5.17-3ubuntu4] libibus-1.0-5/bionic-updates 1.5.17-3ubuntu5 amd64 [upgradable karin@Budgie-Linux-HP-ProBook-650-G1:~ karin@Budgie-Linux-HP-ProBook-650-G1:~ sudo apt full-upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages will be upgraded: gir1.2-ibus-1.0 ibus ibus-gtk ibus-gtk3 libibus-1.0-5 5 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. Need to get 4,787 kB of archives. After this operation, 8,192 B of additional disk space will be used. Do you want to continue? [Y/n] y Get:1 bionic-updates/main amd64 libibus-1.0-5 amd64 1.5.17-3ubuntu5 [134 kB] Get:2 bionic-updates/main amd64 ibus amd64 1.5.17-3ubuntu5 [4,556 kB] Get:3 bionic-updates/main amd64 gir1.2-ibus-1.0 amd64 1.5.17-3ubuntu5 [66.5 kB] Get:4 bionic-updates/main amd64 ibus-gtk amd64 1.5.17-3ubuntu5 [14.9 kB] Get:5 bionic-updates/main amd64 ibus-gtk3 amd64 1.5.17-3ubuntu5 [15.5 kB] Fetched 4,787 kB in 2s (2,172 kB/s) (Reading database ... 253380 files and directories currently installed.) Preparing to unpack .../libibus-1.0-5_1.5.17-3ubuntu5_amd64.deb ... Unpacking libibus-1.0-5:amd64 (1.5.17-3ubuntu5) over (1.5.17-3ubuntu4) ... Preparing to unpack .../ibus_1.5.17-3ubuntu5_amd64.deb ... Unpacking ibus (1.5.17-3ubuntu5) over (1.5.17-3ubuntu4) ... Preparing to unpack .../gir1.2-ibus-1.0_1.5.17-3ubuntu5_amd64.deb ... Unpacking gir1.2-ibus-1.0:amd64 (1.5.17-3ubuntu5) over (1.5.17-3ubuntu4) ... Preparing to unpack .../ibus-gtk_1.5.17-3ubuntu5_amd64.deb ... Unpacking ibus-gtk:amd64 (1.5.17-3ubuntu5) over (1.5.17-3ubuntu4) ... Preparing to unpack .../ibus-gtk3_1.5.17-3ubuntu5_amd64.deb ... Unpacking ibus-gtk3:amd64 (1.5.17-3ubuntu5) over (1.5.17-3ubuntu4) ... Processing triggers for libgtk2.0-0:amd64 (2.24.32-1ubuntu1) ... Processing triggers for gconf2 (3.2.6-4ubuntu1) ... Processing triggers for mime-support (3.60ubuntu1) ... Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ... Processing triggers for libglib2.0-0:amd64 (2.56.4-0ubuntu0.18.04.4) ... Processing triggers for libgtk-3-0:amd64 (3.22.30-1ubuntu4) ... Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ... Rebuilding /usr/share/applications/bamf-2.index... Processing triggers for libc-bin (2.27-3ubuntu1) ... Processing triggers for man-db (2.8.3-2ubuntu0.1) ... Setting up libibus-1.0-5:amd64 (1.5.17-3ubuntu5) ... Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ... Processing triggers for hicolor-icon-theme (0.17-2) ... Setting up gir1.2-ibus-1.0:amd64 (1.5.17-3ubuntu5) ... Setting up ibus-gtk:amd64 (1.5.17-3ubuntu5) ... Setting up ibus-gtk3:amd64 (1.5.17-3ubuntu5) ... Setting up ibus (1.5.17-3ubuntu5) ... Processing triggers for libc-bin (2.27-3ubuntu1) ... karin@Budgie-Linux-HP-ProBook-650-G1:~

  So yes this worked for this instance on command line... however

going into settings or software GUI or software updater GUI the
Authentication Required screen still comes up with Authentication
failed and the field for the password is no functioning.

  I tried the solution sudo nano visudo to add [username] ALL=(ALL)

ALL but that has not worked. Yes the file created visudo is in
/etc/sudoers.d/ now…

It might help to know that I can not mount network drives automatically. I have to go to terminal and use sudo mount -a
I am thinking there must be a permissions gap or loss for sudo or root or a disconnect between the user and sudo user group…
I have tried to check in the users in settings but the GUI is locked …
and I admit I have never run into this problem before. Is it a new security thing for the Budgie flavour?

Nothing to do with Budgie - something is just weird with your install. There is no need to change visudo and from a security viewpoint - isn’t recommended.

Can you please create another administration user account and login. Check if the software updater and GUI perform correctly?

Thanks for continuing to try to help with this. I wiped the drive and restarted with a fresh Budgie install. Only this time slowed and paid better attention.
The first thing that came up was a quick crash notice that there had been a system error. Next a notice that gnome-control-center had a problem. Everything worked fine. Adding cifs-utils helped with the auto naming of network drives (though it can not auto mount at log in as sudo/root privilege is not recognized)
Everything else loaded as expected except I actually noticed that Thunderbird is a BETA version in the Software center. Thunderbird-BETA has some serious quirks (made perhaps worse by the sudo anomallies on my system). These re the two reasons I orginally started on my quest for a sudo rights “fix”…
Lessons learned: Look before you install from the Software program… Libre Office has two versions, one with and one without Base…the one without Base is an older version and not listed as ‘stable’; Thunderbird-BETA has some odd behaviours and I have lost 3 weeks of email (we will all live, just disappointing)… and I have no idea why the fstab can not mount the media automatically.
In the state the system was I could not access any user attributes.
I love Budgie (though I am regretting a little bit moving away from Kubuntu) and want this project to work as well if not better. How can I help resolve these issues?

You didnt mention what type of network drive but I assume a samba drive.

This article looks promising

Do check first in the software center whether the software you are using is a repo version or a snap. If you look at the detail in the app and scroll to the bottom it will tell you.

The beta version is probably a snap.

You could always just install Thunderbird from command line I.e.

sudo apt install thunderbird

Libreoffice is already installed… unless you are using the minimal install? The minimal install does take alot more effort to get fully functional … so is only really recommended for those that want to fully customise everything and can work out the various intra-actions

Way cool!

     The link you sent was

very helpful!

     testing it out, I made

a few changes (it would not work with the suggested addition(s)
to fstab)

This worked for me:


/media/ThunderPublic cifs
0 0

    Using the suggested

example :

// /media/share cifs credentials=/home/user/.smbcredentials,users,rw,iocharset=utf8,sec=ntlm 0 0
      rendered the system

to not recognize the /media/drivename and halt.

    For inexplicable

reasons this also solved the USB being unable to mount without
root privilege at boot. If you have thoughts on this, i would
love to know.

    I install the default

(get everything) version of Budgie. The default LibreOffice
does not have Base, so I found removing it and finding the
LibreOffice marked as the STABLE status had the Base program. It
was interestingly a much newer version as well.

    Both versions are in

the Software Center. Yes downloading Thundnerbird via the
command line is how I solved the problem. It was just curious
that the only option for thunderbird is a beta version. Also,
for unknown reasons the BETA version does not seem to store
files /data in the .profiles folder so hence the loss of email
during the time I was struggling with Budgie and the rights
issues. I have yet to find where those files/data/emails went.

    Thank you so much for

all your help!