Budgie Desktop Settings Not Opening

When I click on the Desktop Setting icon, the app won’t open and finally logs me out of the system.

Restarting UB didn’t help.

I tried to open the settings window from the terminal (sudo budgie-desktop-settings) and get the following output:

** (process:1754): WARNING **: 08:38:15.029: budgie-desktop-settings.vala:27: Failed to launch settings UI: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.budgie_desktop.Panel was not provided by any .service files

budgie-desktop-settings should not be run as sudo.

What version of ubuntu budgie are you using?

Please can you reinstall budgie to check if all the dependencies are ok:

sudo apt install --reinstall ubuntu-budgie-desktop budgie-desktop-environment budgie-desktop budgie-core gir1.2-budgie-1.0 libbudgie-plugin0 libbudgie-private0 libbudgietheme0 libraven0

Then logout and login.

I ran sudo, because budgie-desktop-settings wouldn’t return anything.

But the listed commands solved the issue.

Many thanks for your, as always, swift and professional help. :slight_smile:

1 Like

Side note : you shall never use sudo to launch any « graphical » program. Never. This may corrupt permissions on files used by your « graphical » session to run.

sudo → only for programs in command lines, in terminal or console.

many thanks for clarifying … :slight_smile:

Can you clarify this statement? I’m a noobie and I’m trying to figure out why a program installed with root permissions. If you are prompted to enter your password to open a program does this mean in installed incorrectly? I’m the only user of my machine

I installed with synaptic and had to enter my password to install. When i tried to use the program it failed saying I didn’t have permission which led me to find that the program was owned by root. The program in question id fslint

⋅ Programs whose purposes are to modify system files will ask your password to act as root. Things like gparted, users-and-groups, network-manager settings… These are administrative tasks at system level.

⋅ When you install a program, it’s normal you need to provide password, as the installation process will write files into your system, ruled by root user.

⋅ Now fslint. It should not ask your password to be launched. By default it’s launched by [ you as a normal user ] ready to work on your personal folder /home/you

Try to launch it from terminal by typing


and if there are error messages in terminal please report them here.

https://doc.ubuntu-fr.org/fslint ( french )
http://booki.flossmanuals.net/fslint/index ( english )

The error I received was:

Gtk-Message: 15:53:35.866: Failed to load module “canberra-gtk-module”

I saw this same error msg in a different topic as well. i will go back to look at that. The gui launched fine but a search for duplicate files returned 0 results

Hello Sissy,

check first if you have libcanberra installed by giving dpkg -l | grep canberra on a terminal, then install it -if missing - by giving sudo apt install libcanberra-gtk* … it shoud work.


1 Like