Bug report - 18.04 won't install on HP laptop - grub2 install fails

Newbie here - not sure if this is where I report bugs to the Developers?

Tried twice to do clean install of 18.04 on a HP laptop - 14-b029T (reformatted HDD, as I always do, to 4 partitions; namely, /boot, swap, /, /home) . BIOS set to legacy or compatibility mode, and EUFI turned off.

Previously held 17.04.1 (64 bit) which was working well… (well, except it was over quick to pop up a notification of “something went wrong” if an action didn’t happen quickly enough - even it did still work - eg the software site was slow).

The problem is the bootloader, Grub2 fails to install.

The error message is something like "grub-efi-amd64-signed package failed to install into / target / "

It carries on to warn the OS won’t boot.

Tried twice. clean. Fails each time.

Did a clean install of 17.04.1, no problem… working well.

I may be my imagination, but it might be that the iso of 17.04.1 initially installs grub (then grub2 with subsequent updates), but 18.04 tries to install grub 2 straight up.

maybe my lappie just doesn’t like grub2 ?

I’m staying with 17.04.1, updated (but without optional extra NIVIDA, INTEL prop’ drives installed) and let the “dust” settle for a few weeks. I’ll wait for the next 0.1 version to hit the desk.

cheers to all,

The laptop was 14-b029TU.


Oh. Also it’s a small peeve that the install has the “update as you install” (not the exact wording) greyed out and with no option to un-check it. I’ve previously found it better to do it later. I have had installs fail, in the area I live in, by trying to do too much at the install phase. Just want a successfull basic install to take is my first priority.

Could the Developers allow un-checking of that install option ?

all the best,

Please use the live session.

Double click the icon on the desktop to install.

When the installation fails open a terminal then type

ubuntu-bug ubiquity

This will report the issue to launchpad including all the logs so that your issue can be diagnosed.

N.b. you mentioned that grub2 signed failed. That tells me that either the installer hasn’t detected that you have switched off secure boot or that you really haven’t turned off secure boot in your uefi boot settings.

I’ve also experienced the same thing. I’m not sure if it’s overly helpful feedback, I’m mainly putting this here in case somebody else had a similar issue and it’s not fixed by the time they install things, but I had Budgie 17.10 installed and I tried installing 18.04 on another partition and it failed at the end with the grub2 error. I ended up solving it after first trying to make an EFI partition with 200 MiB which allowed the grub2 installation to finish, but it gave me an error about an unknown filesystem and again I was left at a loss. Using this link here I downloaded the boot repair and it fixed everything. Good luck (if you haven’t fixed it already.)

Yep. This is now a confirmed bug affecting all flavours.


Boot repair is indeed the workaround. This will likely be fixed with the 18.04.1 iso’s