Can I use a Roku as a second display for a laptop

Hello. :slight_smile:
I have an older laptop, an HP Elitebook 6930p. I threw Budgie on it because I was surfing for a distro that was light enough to run without it being too slow.

Everything’s working fine except I have two issues.

  1. for some reason, I can’t get the laptop to recognize a usb mouse/keyboard dongle when I put it in a usb hub, but it works fine if I stick it in one of the laptop’s usb ports themselves.

  2. I have a 32" Roku TV. I am downsizing so I sold my tower to a friend, and booted up this old laptop. The Roku has three HDMI ports on it. The laptop doesn’t have an HDMI but it has a VGA, so I bought a VGA to HDMI adapter. It worked fine when I tested it on the (Windows) tower, but I can’t seem to get the Roku to recognize it coming from a Linux laptop.

Any suggestions?

Hey Granny,

  1. Did you try all your USB ports for the hub? Is there at option to power the hub itself? It could be the USB ports on the laptop don’t pass enough power thru to power the hub itself. Newer USB ports might? I have an external backup drive that wants two USB ports, one for the data and one for the power draw.

  2. Have you verified the VGA port itself works? It may have nothing to do with your HDMI out. I have an HP Elite SFF desktop, and it has both HDMI and VGA. Both work flawlessly on Linux kernel on the current 20.04 kernel (end of Sept 2020) I know this may be difficult, but find a pal with a VGA setup, or try a used computer shop. It’s good you were able to test the other contacts points for your hardware on another OS.

I only ask you to check your HP hardware because you have stated twice how old you feel this laptop is. Good for you downsizing! It’s hard to let stuff go :slight_smile:

Thanks for the reply. :slight_smile:
It’s a brand new cable so while it’s unlikely that that is the culprit, it is possible. I don’t have any way to test that, short of getting an adapter and another cable. I’ve got lots of cables in my ‘computer graveyard’ (a 30-gallon plastic tote) so maybe I’ll pick up another adapter and see.

As for the ports, yeah. I plugged a different hub (I have four or five floating around here, I almost never get rid of computer stuff) and plugged my two 1Tb external drives into a different port on the lappy and Budgie recognized both right away.

I plugged both of my phones into the same hub and tho they’re charging, the system didn’t seem to open them up. But that might be my phone settings and I haven’t had coffee yet, so I’ll mess with those.

Otherwise, I’m loving the heck out of Budgie. I just installed Zoom (to yak with my daughters and grandkids) and it worked, perfectly, ‘right out of the box’.

Insofar as watching the movies and tv shows I have on the one external (the other one’s almost empty), I can just pop that into the usb port on my other Roku that I use for an Xbox monitor and that should be fine.

I had a setup in Minnesota when I lived there, where I used the laptop (with it folded shut, wireless mouse/kb and lots of externals) sort of as a mini-docking station. I had two monitors hooked up at that time, using Linux Mint (this was about a decade ago). I tried the standard Ubuntu at first, and tho the screen would light up on the second monitor, it would just stay green and I couldn’t do anything with it. I switched the laptop over to Linux Mint and immediately it recognized the second monitor and was like, “oh, yeah, here you go, two displays, w00t!” :stuck_out_tongue:
So I’m hoping to do something similar here. I may buy a newer laptop with the money I get from my tower and sell this one or give it to a family member. They’re not real computer-literate, so I can set it up so that they can surf the net and watch youtube and go on social media, and not have to worry as much about viruses and trojans and the like.

Budgie FTW!

  • thoughts before coffee *

I can’t get the laptop to recognize a usb mouse/keyboard dongle when I put it in a usb hub

I am a bit confused, I assume you have a USB A port right, didn’t think that standard supported hubs?

Granny, if the phones are iPhones, you won’t have access to anything but the camera. There are tricks to get into the apple system, but after some experiences trying I have decided to leave them out. My old Samsung android plugs into and allows access to pretty much everything, including apple computers. I really wanted to load my own music, and tried so hard using Rhythmbox and gPod, but I had little success.

I think once you have the settings right, you might continue to use your HP laptop in a similar manner: more as a hub with the laptop closed and put aside.

Consider setting this old HP laptop up and gifting it to a less computer literate family member once you buy your newer laptop. Go get that coffee!

lol. Probably, yeah. But it’s also fun trying to get everything to work on it. That’s the fun of Linux for me.

Me: “ooooh, looky, shiny new repos!”

My laptop: AGGGGGGGGH! - * breaks *


My laptop:

Me: * reinstalls, has everything up and running again in about 20 minutes * "I’ll never do that again, I-

ooooh, shiny new repos!"

OMG that is me too. I’ve reinstalled Ubuntu Budgie more times than I can count, and I keep changing my mind about distros as well. Have you tried:

elementary OS? Solus Budgie? Manjaro Budgie?

Those last two involve slightly different package manager commands in the terminal. If you’re going to reinstall the OS anyways, you should try them all.

I’ve tried Elementary OS but on a different laptop. It was okay.

I had a weird thing, also, with that other laptop (about four years or so ago). There’s a version of Red Hat, PCLoS, I think?

Anyway, the liveusb worked great. Got on the net, could see every partition and the folders in them, etc.

Every time I tried to install it, tho, I got a kernel panic. Weird.

I haven’t heard of the other two versions of Budgie.

Oh, and I switched both of my phones to USB - mtp, and Budgie’s lie, ‘yeah, there they are!’

Much easier to move photos to my laptop that way, than emailing them to myself.

follow the trail to askubuntu.

Fragmede says: In absence of additional data, I’m going to suggest turning ACPI off, as described on askubuntu. Since you’re able to get the kernel to boot, and given the age of the laptop, and the few lines of the traceback visible, it seems possible that bad ACPI information in the laptop’s BIOS is causing the kernel panic.