Question on slow internet and weird Realtek option

Hi Guys,
Still learning slowly. My internet have been slow since I updated two weeks ago or so. There are a few issues I cant quite get my head around the first is below:

Screenshot from 2020-11-24 10-30-27

In the upload there is an option for Realtek driver to be selected, but it is greyed out and cannot be selected. I have installed Realtek RTL8168 and it worked briefly till I updated again, yesterday. I tried reinstalling again but I get the message that 8168 is the newest available.
Is there a way to enable the driver as shown above in the picture? Maybe via the terminal? Under the network settings there are no options available.

The second issue is that I cannot use my phone to connect my laptop to the internet in Budgie 20.04 at all (By this I mean I connect my phone and use it as a “modem”? - I really have no idea what that is called). Is that also related to the driver issue? If not what can I do to fix that?
I would Google but as I have said I have No idea what it is called or how to even phrase it. I am very much an end user.

Thank you in advance for the replies!

Hi there,

wireless issues are generic to all Ubuntu Flavours. So do ask on the regular Ubuntu support forums - and where a much wider audience can help as well.

Since you mentioned an update - possibly this was a kernel update. Do check if booting to an older kernel restores things into a working manner i.e.

Reboot - immediately after the computer bios splash screen press and hold the shift key to display Grub. Select advanced options. Choose the earliest kernel that you can see.

Have you rebooted since the update? Is the issue there after booting or does it get weird after a while?
If you haven’t I would advise to restart your nertwork services, it works often for me whenever I hit some kind of Internet or networking issue.

Should be:

sudo systemctl restart networking

sudo systemctl restart network-manager

(or maybe kill and restart the applet in budgie, not 100% sure)

Could be your card that is not properly recognized or loaded.

Check with:

lspci | grep 8168
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)


inxi -n
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
IF: enp2s0 state: down mac: xx:xx:xx:xx:xx:xx



(don’t have output on that one as I’m on Manjaro on this laptop but you should see your enp2s0 equivalent there)
(also works for wi-fi but it’s iwconfig)

Finally check if the module is properly loaded

lsmod | grep r8169
r8169 98304 0
libphy 147456 2 r8169,realtek

(see inxi -n for exact driver to look for)

Regarding your phone, it’s called “tethering” whether through a wi-fi ad hoc hot-spot or USB tethering.
It’s probably related to your driver issue. If I connect my phone via USB to my laptop and select USB tethering on Android, I got the Internet working straight away on my laptop (this emulates an ethernet device on Linux).