Newbie first time install fail

Hi all

Would like to try Linux again after many years with windows.
Liked the look of the Budgie and would like to test it.

Have bought an new computer for the purpose. That was maybe an mistake, since I wanted a motherboard with the newer intel 1200 chip.
My problem is to get internet up an running. Ethernet is onboard and is an Realtek.
Have tried for a couple of days now, to find an solution to install the drivers with no luck. Seems like the iso file has drivers, but I cannot find out how to make the usb work as an cd-rom.
Went down to the store an bough an USB wifi stick from Netgear (AC600), but did nok work as well.

Have tried two different versions og the Budgie, but with no luck. I have now the 21.04 version installed.

For now,I am thinking of maybe just add windows on the computer and use it for a year and see if the ethernet on the motherboard maybe will work later.
But I hate to give up :frowning:

hey Geir! No mistakes, you’ve chosen a great OS to work with. The driver is waiting for you to install with your computer, but you need to get the computer online to find the correct driver. That’s awesome your new PC has ethernet onboard, and it sounds like you have a Realtek USB wifi stick?

I use a RaLink USB wifi stick (branded TP-Link), I’m sure they’re similar? You have to let the OS find the correct driver online (everyone’s PC has slightly different hardware) but you can’t do that without wifi! Lug your setup closer to the modem, and use that awesome new ethernet port to plug directly into your modem. These instructions are for a macbook, but are essentially the same for any PC.

Click on Show Applications > Additional Drivers > (You may have to dig around for it, I don’t have it open at the moment) In the Additional Drivers tab look for any proprietary drivers to be installed. Disconnect the wired connection and I would suggest rebooting after installation, you may then scan for wireless access points.

If Additional Drivers is not installed then in Ubuntu Desktop > Settings (upper right corner) > Applications > Additional Drivers > “Open in Software” button > Install

Hi and welcome!
First of all … dont give up!

Official support sites such as askubuntu.com and ubuntuforums.org can help here as well. They have a much wider audience with experts on this area.

You are a tad unfortunate here. Realtek dont have great linux support (company issue).

Netgear also are pretty poor with their linux support. So another company to stay away from.

There are workarounds available usually involving compiling source code. Not newbie friendly I am afraid but can be done if you are ambitious enough.

My advice would be to return you netgear and replace with another company (not realtek).

Once you have a working usb wifi option then start working through the onboard realtek issues.

But first do double check the additional drivers screen first as Jason mentions … you may get lucky!

Thanks for suggestions.

I did a search in additional drivers, but it is nothing there.

I cannot return the the new motherboard I am afraid. The computer is running with Budgie 21.04 on it allready. Would think my first goal is to find a way to get in online so I can do all updates and install a driver for the onboard realtek ethernet. I think I can return then USB wifi from Netgear.
The shop also had a “no name” USB cable ethernet" adapter. Maybe this is better luck trying?

As long as the system is not online, it is not so easy.Also tried to install a Realtec driver downloaded to the USB, but seems like i dont have “make install” option eather without online update.

Have also tried to connect my Android phone to the USB and share internet. No luck eather…

No harm in trying. A good shop would allow you to take along a USB drive with Ubuntu on it to allow you to boot your laptop (I’m assuming its a laptop…) and try the cable in house (try before you buy).

I am afraid it is a big tower…
The goal for the new computer is to function for work and for media file storage.
Will try to go back with the USB wifi and get the USB ethernet. If that is not working, I need to look for a new onboard ethernet card that can work out of the box…

note also - I’m surprised android usb tethering doesnt work for you. It should be plug and play.

Yes, that was my first try. Maybe I have the wrong cable or something. It is the standard cable that followed the phone for charging. My phone is quite new, with latest android on it.

do try the bluetooth connection as well - article I linked to mentions that.

Have no onboard Bluetooth, but if a USB stick could work without drivers, it could be a solution.

Have now tried a new cheap USB 2.0 USB ethernet adapter.
And, like magic, internet connection poppet up! :man_dancing:
Did an quick update of the system and installed my Norwegian language packs and are now ready to play.
Will still try to fiind an solution to get the inboard Realtek ethernet card to work, since it should be more speedy. Would think this is more easy now with an working connection.
We will se.