Sudden loss of wifi speed

Hi, I am trying to figure out what happened to my wifi signal. The signal was fine on my laptop up until a few days ago and now I am back to dial-up speeds (0.1 Mbps). My work laptop (runs on Windows) is getting normal speeds (~30 Mbps download/5 Mbps upload). I was googling for a solution but am not a developer so I wasn’t 100% sure that the solutions were right for me. Here is the info on my computer:

Ubuntu 18.04.3 LTS with a RTL810xE PCI Express Fast Ethernet controller. I include this info because people on the other internet forums were talking about how it is a problem with the Realtek driver, but I don’t want to go off half-cocked and start putting on a new driver (the lwfinger/rtlwifi_new driver on github was suggested) because I don’t know if that is the correct driver to use (and my computer is too slow to download the file).

I tried to switch my antenna using this (from but wasn’t sure if I was doing it right (like, do I type in the " or is that just bracketing the command in the line of text?):
sudo -i
echo “options rtl8723be ant_sel=2” > /etc/modprobe.d/rtl8723be.conf

It says that all of my software is up to date. Is there something else that I can check/fix/install? Thanks!

It’s worth checking to see if a kernel update is the cause of your issue.

Suggest reboot, immediately press and hold the shift key or escape key after the bios splash screen to display grub. Choose advanced options and select an older kernel to boot with.

That fixed it! I should have just come here first rather than trying to suss it out on my own. Thank you.

Is there anything that I need to do to make sure that it doesn’t revert back to the wonky kernel?

This should get you going:

Note - you should report this a a bug to the kernel developers otherwise it issue cannot be fixed in later kernels.

In a terminal type:

ubuntu-bug linux

Hi, I spoke to soon with my response. The computer worked normally right after I did the restart but the next time that I used it we were back to 0.2 Mbps. I did another restart and made sure that I booted with the older kernel but it didn’t make a difference this time. Any other suggestions? Thank you!

To be honest. I am not a wifi expert.

This question would readily be answerable where the experts do hangout … and

Do use the wireless info script and post the results with your question

Thank you! I will try that when I get home. I really appreciate your help.

HI, I didn’t get much help on ubuntuforums (the only two responses were just to correct how I had asked the question). I tried switching the antenna and disabling 802.11n but now it just seems worse. I was thinking that I would just start from scratch and either restore everything in the OS back to the original settings or reinstall budgie. I still have my installation USB but wasn’t sure if there was a way to restore without completely pulling the plug. Is there a command that will do that? Thank you!

That’s disappointing.

Did you create a question on also? I would try them as well.

One of the install options in the installer is to Reinstall - it will try to keep your home folder but replace the backend system files. You may have to install your apps again. Do remember though to make a backup of your important files just in-case things go wrong.

Hi again!

I have posted on askubuntu but haven’t yet received a response. I had to postpone doing a reinstall until I can swipe a USB from work tomorrow so I am making a last-ditch effort to fix this my installing the lwfinger/rtlwifi_new driver off of github ( I cloned the driver off of github and think that I built it and possibly installed it. My computer worked great but then I got cocky and did a restart and everything went back the same as before. I did lshw -C network but it still lists the old iwlwifi driver so I think that it didn’t install. I have tried to repeat the process but am getting an error message after
sudo make install:
make -C /lib/modules/5.0.0-36-generic/build M=/home/lyn/rtlwifi_new modules make[1]: Entering directory '/usr/src/linux-headers-5.0.0-36-generic' arch/x86/Makefile:147: CONFIG_X86_X32 enabled but no binutils support ./scripts/ line 26: gcc: command not found ./scripts/ line 27: gcc: command not found make[1]: gcc: Command not found make[1]: gcc: Command not found make[1]: gcc: Command not found make[1]: gcc: Command not found CC [M] /home/lyn/rtlwifi_new/btcoexist/halbtc8192e2ant.o /bin/sh: 1: gcc: not found scripts/ recipe for target '/home/lyn/rtlwifi_new/btcoexist/halbtc8192e2ant.o' failed make[3]: *** [/home/lyn/rtlwifi_new/btcoexist/halbtc8192e2ant.o] Error 127 scripts/ recipe for target '/home/lyn/rtlwifi_new/btcoexist' failed make[2]: *** [/home/lyn/rtlwifi_new/btcoexist] Error 2 Makefile:1614: recipe for target '_module_/home/lyn/rtlwifi_new' failed make[1]: *** [_module_/home/lyn/rtlwifi_new] Error 2 make[1]: Leaving directory '/usr/src/linux-headers-5.0.0-36-generic' Makefile:58: recipe for target 'all' failed make: *** [all] Error 2
My tilex command line is sitting at:

Is there a different command that I should be entering here to finish the install of the driver?

This means that the development libraries such as the compiler are not installed. To install the compiler you need to install build-essential

You may need to install other development libraries as well - but you will not know that until you get passed this initial error.


I ran
sudo apt-get install build-essential
and then
sudo make install
It said that it installed but rtlwifi the iwlwifi driver still shows up in lshw -C network:
WARNING: you should run this program as super-user.
description: Wireless interface
product: Centrino Wireless-N 1030 [Rainbow Peak]
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:01:00.0
logical name: wlp1s0
version: 34
serial: 4c:80:93:62:ec:5b
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=5.0.0-36-generic firmware= ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:32 memory:d0600000-d0601fff
description: Ethernet interface
product: RTL810xE PCI Express Fast Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:03:00.0
logical name: enp3s0
version: 05
serial: 14:fe:b5:9d:97:d6
size: 10Mbit/s
capacity: 100Mbit/s
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=half firmware=rtl_nic/rtl8105e-1.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
resources: irq:16 ioport:2000(size=256) memory:d0404000-d0404fff memory:d0400000-d0403fff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

Is there anything else that I should install? Thank you!