Crashes after compiling budgie desktop

After doing this (from the split thread) and keeping the laptop on for some days, now it has reached a state where the panel consistently crashes after restarting. I might be able to keep my laptop up for sometime in this state, so is there anything that I can do to help debug the issue, since it is getting reproduced consistently now? @fossfreedom

Since you have got a self compiled install you’ll be able to look a the crash file produced and examine it to find out where in the code it is crashing:


1 Like

@fossfreedom, the backtraces do not seem to be very useful. I think debug symbols are missing and I kinda cannot get exactly what to do to compile budgie desktop with debug symbols?

Looking into some meson docs I tried:
meson --buildtype debug --prefix=/usr --libdir=/usr/lib --sysconfdir=/etc …
But the build fails after this :frowning:.
Am I missing something? (Also notice that crash is in libglib so maybe that’s why backtraces are not helpful :confused:)
(Here’s what I get as backtrace:

This will work (just tested)

mkdir build
cd build
meson --buildtype debug --prefix=/usr --libdir=/usr/lib --sysconfdir=/etc

Somehow this does not work for me. plain buildtype works fine but debug fails. Also tried fetching sources again and building without any changes from my side to ensure my changes are not causing build failures.

Plain build type:

Debug build type:

Look at the top of the screenshot … the .ccache… subfolder has a permission error. Looks like the subfolder has somehow changed permission rights from your account name

Yes realized that. Must have happened as I ran one of the commands in a elevated terminal :frowning:.
Sorry for the trouble.

I did manage to get some useful information from backtrace, however the crashes happening right now seem to be something related to notifications and notification-position.

Weird. Notification position is a budgie desktop v10.5 capability. Why though the schema isn’t installed I am not sure.

Do check that you are not accidentally compiling a budgie desktop v10.4 source code base. Check that you have enabled the sources for the backports ppa in update manager -settings before you ‘apt-get source budgie-desktop’

This was right on spot. Enabled the sources for backports and built budgie-desktop again and installed, crashes have stopped now (I guess were happening because of the source being 10.4 and other stuff being from 10.5 I guess?)

So these crashes did not correspond to the crashes that led to this thread then, I guess? Will have wait for some more days now to see if the real crashes appear.