Budgie-panel keeps crashing

I installed Ubuntu Budgie for the first time with 18.04. I like it very much. I had some initial problems, but most of them have been solved. The one lingering problem has to do with constant crashes of budge-panel.

Sometimes it crashes and throws an error. Usually it restarts by itself if that happens. But sometimes it “freezes” (I can’t click anything in the panel at the top, raven won’t open with SUPER+N, etc…)

I can get it to restart if I use the “–replace” argument from the terminal. (budgie-panel --replace)

But when I run that command when the panel is unresponsive, it always outputs errors.

***@***:~$ budgie-panel --replace
** Message: 20:50:12.844: libsession.vala:50: DESKTOP_AUTOSTART_ID not set, session registration may be broken (not running budgie-desktop?)

(budgie-panel:19583): Gtk-CRITICAL **: 20:50:13.390: gtk_widget_set_accel_path: assertion ‘GTK_IS_ACCEL_GROUP (accel_group)’ failed

(budgie-panel:19583): Gtk-CRITICAL **: 20:50:13.390: gtk_widget_add_accelerator: assertion ‘GTK_IS_ACCEL_GROUP (accel_group)’ failed

** (budgie-panel:19583): WARNING **: 20:50:13.695: BudgieMenuWindow.vala:298: Software has no parent directory, not adding to menu

I’m not sure what’s going on here, but this happens multiple times per day and has been happening since installation. I installed using the “minimal install” option from the 18.04 Ubuntu Budgie ISO.

If anyone can help I would greatly appreciate it.


Try doing a panel reset to see if that is the issue.

Slowly add back applets to see if there is one specific one causing an issue with your setup

nohup budgie-panel --reset -- replace &
1 Like

That didn’t work unfortunately. It just kept crashing and throwing the same errors.

What did work was:

sudo aptitude --with-recommends install ubuntu-budgie-desktop

That basically installed all the default packages that I missed with the minimal install, which seems to have fixed the issue.

Most of what was installed, I recognized. I removed quite a bit of it, but left most of the lib packages that I didn’t recognize and that weren’t dependencies for the other packages I removed.

So I assume that something important was missing with the minimal install that was causing the crashes. That may be something you want to look at.


Actually, it looks like the above didn’t solve the issue. (My reply as well as the suggestion in the one above) It started happening again today.

I have no idea what’s causing it, but it’s getting to the point where my desktop is almost unusable. I really like Budgie, and would really hate to switch to default Gnome.

Is there anything else you can think of that I can try?

Not much here to work from :frowning:

Graphics issue? Any proprietary graphics drivers offered to you via gnome software - software & updates - additional drivers?

No additional drivers offered. It’s my understanding that AMD doesn’t offer proprietary drivers for linux anymore, so I’m using the open-source driver that was installed during installation.

I would do a fresh install. Something definitely gone very wrong but without more information such as looking in the logs (menu - logs) think we are into guess work as to what your issue is. I haven’t heard of anything similar before.

Since this starting happening right after a fresh installation, I don’t see how another fresh install would help unfortunately.

I’m at a bit of a loss. I was hoping this would be an easy fix, but that doesn’t look to be the case. Since I can’t continue with constant crashes of the panel, I guess I’ll switch to gnome for now. I’ll keep budgie installed, hopefully something changes later and I can keep using it.

1 Like

This still keeps happening - and not just for fossycakes.

I keep doing a killall budgie-panel to solve the issue - however this is far from ideal.

The panel is only as strong as its weakest part - its applets.

Suggest reset your panel.

nohup budgie-panel --reset -- replace &

Then run for a while - if it isnt crashing then add one applet back to the panel … run for a while etc. That will enable you to diagnose which is the likely applet causing the crashes.

does anyone has solution for this ?

See the post above yours. Start with a minimum of applets, did you try that? If it fails, what and when went wrong?

I just uninstalled ubuntu budgie and moved to another linux os.
thank you for support.

I’m also facing the same issue. It occurs randomly and can’t open raven or type of the menu search box.

1 Like

Yup used to happen to me. Are you using the Global Menu applet or the Plank dock? I’m sure one of them causes this; when removing both and switching to a windows layout, it works.

Plank doesn’t have a single relation to the panel…

Then it’s probably the Global Menu.

I’m not using any of them

I’d suggest starting (as David’s post suggests) with none or only a few.

What a mess guys, I installed Ubuntu again. After fresh install it was working fine but after some updates and restart the computer make the crash again. there is a problem with ubuntu updates definitely.
do we still have a solution for this ? is it possible to test the updates ?