Ctl+Alt+l does not work

Ctl+Alt+l does not work
I also tried: gnome-screensaver-command -l
Any thought?

Have you got both gnome-shell and budgie installed?

Have you got rhe package gnome-shell-common installed?

Did you install budgie manually on a ubuntu desktop install or from the ubuntu budgie iso

What screensaver processes are running?

ps -ef | grep -i screensaver

Have you got the file /usr/bin/gjs

I have GNOME Shell 42.5

gnome-shell-common is not installed

Budgie was install from the ubuntu budgie iso

ps -ef | grep -i screensaver
grep --color=auto -i screensaver

yes I have /usr/bin/gjs

Are you using gdm or lightdm for your login manager?

I’m using gdm for your login manager

Ok your issue is the same as a few other threads here.

Basically GNOME Shell uses a component called gjs that is autostarted on login. This steals the DBUS interface gnome-screensaver requires and this then fails to start.

If you have to to use both budgie and gnome-shell you will have to accept this gnome-shell limitation on budgie with regards to the screenlock not working.

If you no longer use gnome-shell - simply uninstalling gnome-shell-common will uninstall gnome-shell.

You will also need to switch from GDM to lightdm. Ubuntu Budgie uses slick-greeter

I uninstalled gnome-shell-common and it still not working…

I don’t know if it helps but the automatic screen lock is blocked in the budgie control center. I can’t activate it.


So do check if you have set fractional scaling - if you are you cannot enable the lock screen.

If you are just using the standard 100%/200% etc scaing then double check that this setting hasn’t accidently been set

Yes that was the issue. Thank you so much!