23.04 - Screen Lock

It seems that again gnome has decided to upend the function of gnome-screensaver enough to prevent it from working in budgie using Lunar Lobster – such that there is never a lock screen presented anymore

I don’t have gnome-shell installed as suggested here

  • Using the “Lock” button provided next to logout/hibernate does nothing
  • Super-L does nothing
  • /usr/bin/gnome-screensaver is running
  • /usr/libexec/gsd-screensaver-proxy is also running

this shows up frequently in /var/log/syslog

Couldn't lock screen: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.ScreenSaver was not provided by any .service files

this log shows up coming from various pids:

  • gsd-media-keys
  • budgie-power-di
  • gsd-usb-protect

I’m not sure what other logs to look through

Can’t reproduce on any of the lunar boxes atm. Is this a default install? Did you by any chance switch resolution/scaling, and are you fully updated?

In addition to what jacob has asked please check if you have the file /usr/bin/gjs installed. It shouldnt be.

1 Like

I arrived here via a do-release-upgrade -d from kinetic kudu last friday.

aha – this is here.

❯ ls -al /usr/bin/gjs
lrwxrwxrwx 1 root root 11 Apr 11 22:40 /usr/bin/gjs -> gjs-console

Well, it’s my normal 2-monitor setup

xrandr -q
Screen 0: minimum 320 x 200, current 6400 x 2160, maximum 16384 x 16384
eDP-1 connected 2560x1440+0+720 (normal left inverted right x axis y axis) 344mm x 194mm
   3840x2160     60.00 +  60.00  
DP-1 connected primary 3840x2160+2560+0 (normal left inverted right x axis y axis) 597mm x 336mm
   3840x2160     60.00 +  29.98* 

So, after a purge:

sudo apt purge gjs
sudo apt autoremove

then a session logout/login

i’m still unable to get the lock screen to show up

What does gsettings get org.gnome.desktop.lockdown disable-lock-screen say?

1 Like
❯ gsettings get org.gnome.desktop.lockdown disable-lock-screen

well that’s odd… i’m not sure where in the control center this should be swapped. Lemme set it to false and see what happens.

❯ gsettings get org.gnome.desktop.lockdown disable-lock-screen      

Well! The Lock button in the UI and the Super-L Key is working! Nice

Yay! Glad it worked out.

1 Like

Still loving this unlocking. @vlijm and @fossfreedom you guys are terrific!

1 Like