Doesn't work on Pi4

Hi, Installed it on a RaspberryPi 4 with uBuntu Server 20.04 64bit. Installed ok, but when rebooted I couldn’t open a terminal window. In fact nothing would open except Settings, interestingly it also wouldn’t detect the WiFi but it was there as I used it to download and install Budgie in first instance. Had to wipe SD-card.

Mike

From this the start point is the raspi image.

The terminal issue is workaround slightly later in that thread.

Since you started with the server image you perhaps should consider using desktopify since that does all the tweaks and tucks to convert the server image to be raspi compatible.

Thanks, will check that out, very useful :+1::+1:

As to the wifi issue, I have found that on the Raspberry Pi, I could not see any of my 5GHz networks. The 2.4GHz showed up fine. I am not sure if that has anything to do with what you are experiencing. I found out that this has something to do with the country code not being set.

If you edit /etc/default/crda you will see a line that says
REGDOMAIN=

I had to add the two letter code for the country I am in to make it work. Being in the US, I changed it to
REGDOMAIN=US

Now I can see the 5GHz networks on the Network applet.

I found the list of country codes here: https://en.wikipedia.org/wiki/ISO_3166-1_alpha-2

1 Like

tried right now: no need to edit crda for me: network applet shows both 2.4 and 5 GHz wifi.
There’s anyway a problem about network applet: it shows wired connection as down (better: as if there weren’t any wired connection; wired connection switch in network applet is turned off and is impossible to turn it on and in settings too *there isn’t * any wired network ) but in fact wired connection is up, running and healthy. It isn’t a so big problem because the only bother for me is remembering this strange behaviour.

Sil

Sounds like something very specific to the pine64 that the applet needs to understand to display its info correctly.

It must be, because it happened to me too. In fact when I first started Ubuntu Server before even installing Ubuntu Budgie, it said that there was no ethernet connection available, but worked just fine anyways. I have a spare sd card so maybe I’ll try an install with desktopify and see what it does.

Is a Raspberry Pi4, this one. Unfortunately I’m still not able to find out where Pine64 is … at home, I mean :blush: