Home Store Blog

Driver Question

#1

I currently have the nvidia-driver-418 installed and wanted to install the 430 version from the Graphics PPA and I’m getting the following error:

$ sudo apt install nvidia-driver-430 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-driver-430 : Depends: xserver-xorg-video-nvidia-430 (= 430.09-0ubuntu0~gpu19.04.1) but it is not going to be installed
                     Depends: libnvidia-cfg1-430 (= 430.09-0ubuntu0~gpu19.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

My list of drivers:

$ sudo ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:1c.7/0000:08:00.0/0000:09:07.0/0000:0d:00.0 ==
modalias : pci:v000014E4d000043A0sv00001043sd00008659bc02sc80i00
vendor   : Broadcom Inc. and subsidiaries
model    : BCM4360 802.11ac Wireless Network Adapter
driver   : bcmwl-kernel-source - distro non-free

== /sys/devices/pci0000:00/0000:00:03.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001B06sv00003842sd00006797bc03sc00i00
vendor   : NVIDIA Corporation
model    : GP102 [GeForce GTX 1080 Ti]
driver   : nvidia-driver-415 - third-party free
driver   : nvidia-driver-396 - third-party free
driver   : nvidia-driver-430 - third-party free recommended
driver   : nvidia-driver-418 - distro non-free
driver   : nvidia-driver-390 - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

Any idea what might be causing this or what I can try? I’m running a clean install of Ubuntu Budgie 19.04.

Doug

#2

Can you double check you are fully up-to-date?

sudo apt update && sudo apt upgrade

What happens if you then run the following?:

sudo apt -f install
#3

Just a standard update and nothing else. I tried installing 430 again and same error.

My 19.04 install is from the release bits, fresh install.

#4

Very odd. I just done this on a live 19.04 64bit ISO

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt install nvidia-driver-430

That completed successfully

#5

If you go into ‘Software & Updates’ and ‘Additional Drivers’ does it say you’re using the open source or proprietary version of the 430 driver?

#6

It didnt since I dont have nvidia graphics.

Just that it installed cleanly.