UBudgie 20.04 + Nvidia GF116 [ GeForce GTS450 Rev.2 ]


As professional activities are slowed down, I thought it was a good moment for upgrading my work-pc - still on beloved Ubuntu/Unity 16.04

So I’ve tried UBudgie on that machine from a live-usb and all looks fine : 2 monitors with right resolutions ( no HiDPi here ), ethernet network ok ( no wifi on that machine ).

Confident, I installed UB on it, deleting dear Unity 16.04 ( and also a « regular » Ubuntu 18.04 installed on dual boot which used to work with nouveau. )

And now I regret. On reboot, only one monitor fires up, and with a wrong resolution I can’t change 1024x768px.

Using additional drivers, I see system right after install is using nvidia-driver-450-server.

I changed that back to xserver-xorg-video-nouveau : nothing changed on next reboot, only one monitor and wrong resolution.

I removed-purged anything nvidia related, no better luck.

Another weird thing, in whatever situation, I had never been able to see GRUB and eventually access « recovery mode ». Hitting [ Esc ] or [ Shift ] had zero effect - not the first time I see that in Budgie.

myself@PROLiANT:~$ lspci -vnn | grep -A 12 '\''[030[02]\]' | grep -Ei "vga|3d|display|kernel"
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF116 [GeForce GTS 450 Rev. 2] [10de:1245] (rev a1) (prog-if 00 [VGA controller])
	Kernel modules: nvidiafb

myself@PROLiANT:~$  sudo lshw -enable pci -class display
[sudo] Mot de passe de myself : 
  *-display NON-RÉCLAMÉ     
       description: VGA compatible controller
       produit: GF116 [GeForce GTS 450 Rev. 2]
       fabricant: NVIDIA Corporation
       identifiant matériel: 0
       information bus: pci@0000:01:00.0
       version: a1
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress vga_controller bus_master cap_list
       configuration : latency=0
       ressources : mémoire:d6000000-d7ffffff mémoire:c8000000-cfffffff mémoire:d0000000-d3ffffff portE/S:2000(taille=128) mémoire:c0000-dffff

myself@PROLiANT:~$ xrandr 
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
   1024x768      76.00* 

My assumption here : that quite old graphic card is no longer supported by any nvidia driver in Ubuntu and Ubiquity should not install any of these nvidia drivers ( in my situation, I understand why it may be interesting with recent cards ).

Since everything worked fine in usb-live-session, what are my best chances to get a working system without reinstalling ?

In other words what is now actually preventing nouveau from working, as just as it was working in live-usb-session ?

And to be honest I don’t mind re-installing - my DATA are safe - but I’d like to understand why once installed, it’s not functional.

1 Like

Did you remember to remove the xorg conf file after uninstalling the nvidia driver? /etc/X11/xorg.conf ? (I think thats the file nvidia writes)

If you run ubuntu-drivers devices what does this show?

I remember not removing any file, I just did something gross like

sudo apt remove --purge *nvidia*

That machine being on my work place, I won’t be able to check before thursday.

So if any /etc/X11/xorg.conf exists I’ll rename it.

And will output ubuntu-drivers devices

You give me hope, it’s a great responsibility :slight_smile:

Mmm can’t find anything looking close to an xorg.conf file.

@PROLiANT:~$ ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:03.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001245sv00001462sd00008095bc03sc00i00
vendor   : NVIDIA Corporation
model    : GF116 [GeForce GTS 450 Rev. 2]
driver   : nvidia-340 - distro non-free
driver   : nvidia-driver-390 - distro non-free
driver   : nvidia-driver-460 - distro non-free recommended
driver   : nvidia-driver-450-server - distro non-free
driver   : nvidia-driver-418-server - distro non-free
driver   : nvidia-driver-460-server - distro non-free
driver   : nvidia-driver-450 - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

I’ll go to a reinstall’ - unticking the « install third party software ».

Its recommending that you should be using the 460 driver. So that’s odd why the installer chose the 450 …

But yeah - reinstalling will ensure nouveau is the initial default.

1 Like

And indeed, reinstall’ without enabling third party software did the trick.

I don’t dare trying installing nvidia 460 though.

1 Like

it’s happened to me too, just with an old MSI-Don’tKnowWhat that lead to nvidia-390 drivers: no more than 1024x768 but fortunately, reverting to nouveau did the trick

From yourself and @Coeur-Noir observations, sounds like Nvidia has pulled support from older cards.

I would encourage you all to report these findings to launchpad via one of the nvidia packages. This is so that the Canonical maintainer is aware and possibly will remove the offering of these proprietary drivers.

How did you revert to nouveau ?

My main problem here is : once Nvidia installed ( at start, by ubiquity installer ) I did not manage to revert to nouveau. How did you do that ?

I had to completely reinstall UBudgie while ensuring I did not enable « third party software » in Ubiquity installer.