Screen resolution going back to default (Ubuntu Budgie 20.10, NVIDIA, Intel i7)

Hi everyone

I am using a fresh out of the box Budgie 20.10 install on my primary desktop.

  • i7 2600k
  • 16GB DDR
  • GTX 1070

After install, my full screen resolution was correctly detected, looked amazing (1440p). After a reboot though, things shift back to 1024x768 and I can’t select a different resolution from the GUI. The NVIDIA driver appears to be loaded.
nvidia-smi shows

Tue Nov 10 13:18:12 2020
| NVIDIA-SMI 450.80.02    Driver Version: 450.80.02    CUDA Version: 11.0     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  GeForce GTX 1070    Off  | 00000000:01:00.0 Off |                  N/A |
| 33%   42C    P0    33W / 151W |      0MiB /  8116MiB |      2%      Default |
|                               |                      |                  N/A |

| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|  No running processes found                                                 |

This is the second attempt at this, first time I used a more maximal approach when install budgie (all the apps out of the box), same issue as with this more minimal one.

Any help much appreciated.


Sounds like a bug in the proprietary driver :frowning:

Does any of this help you?

Thansks - I followed Jim Salter’s approach (saving nvidia settings to /etc/X11/xorg.conf) and that seems to have made no difference.

My xorg.conf now has

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-2"
    Option         "metamodes" "2560x1440_144 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24

in it, which matches the answer given in that link - but I still get bogus resolution following a reboot.

It turns out I can kick this into life by running sudo systemctl restart display-manager - not ideal, but it’s nice to have 1440p again :smiley:

Please file a bug report so that the Canonical devs are aware

ubuntu-bug libmutter-7

OK thanks I will try and do that.

james@beasty:~$ ubuntu-bug libmutter-7
dpkg-query: no packages found matching libmutter-7

ah - typo - libmutter-7-0

OK I submitted a bug, but unfortunately that PC had to go into a shipping container tomorrow morning, so I’m out of troubleshooting time for the next 12 weeks. :smiley: