Home Store Blog Development

Wide Monitor Resolution Options limited


#1

Hi all. I recently invested in a 3440 x 1440 wide monitor (long story, it was on deep discount and I couldn’t resist and hated my current monitor) and it’s been great so far. Some apps and gaming titles really don’t do well in this resolution (or run at all) so I’d occasionally like to set it back to the more standard 2560 x 1440 resolution. However, in Budgie display settings for resolution, the only offered options are: 640 x 480, 800 x 600, 1024 x 768, and 3440 x 1440.

That seems far too limited. I have this monitor attached via mini-Displayport to a laptop with an NVIDIA card and I close the native screen. I can change the NVIDIA app resolution settings, but all this accomplishes is putting black bars on the right and left side of the screen to adhere to 2560 without changing the underlying 3440 resolution, so what’s on the far right and left of the screen is hidden.

Any ideas on how to add more resolutions to Budgie settings? I’ve tried xrandr commands I’ve found online, but those haven’t worked. Thanks!


#2

something like this?


#3

Me too , have tried xrandr command but it doesn’t work . Do you have solved your problem ?


#4

Honestly, no, I never solved it. I moved my main machines over to Manjaro KDE (for lots of reasons - rudderless Budgie upstream development, dislike of the increasing Snap-ification of the Ubuntu ecosystem, unhappiness with breaking PPA’s, etc) and have not had that resolution problem at all.

I kept my gaming machine on Ubuntu Budgie, and thankfully Valve’s Proton for Steam seems to automatically solve this resolution problem for games, and for productivity software that needs the step down of resolution, I use Manjaro KDE for that…


#5

I see. That is unfortunate , but thank you for the information . Hope this issue can be solved later


#6

I’m playing around on a test machine with Marjaro Budgie. I should hook it up to the wide-screen monitor and see if it has any issues. That’ll test whether it’s an Ubuntu issue or a Budgie issue… My guess is Budgie, but we’ll see…

Addendum: This Solus forum entry makes me think Budgie is where the issue is… We’ll see… Are you using a monitor attached to a laptop or is it the primary monitor of a desktop?


#7

Primary monitor attached to a desktop. I have this issue when I change into my new graphic card. Before My display is okay and sharp . There is a display resolution fit to my monitor (mine monitor is 1440x900) when I use my old graphic card . Maybe because of the new graphic driver I dont know. Now I can’t find 1440x900 fit for my monitor and I use 1400x900 instead . It still okay but show some blur if I see it thoroughly

note :
I search google about it and people using Ubuntu can solve this using xrandr to add custom resolution . But in my Budgie it doesn’t work . Maybe something in the Budgie preventing this.


#8

Budgie Desktop has no responsibility for screen resolution stuff. That is your graphics driver & maybe the GNOME Mutter window manager


#9

Yeah, then my guess is Mutter, which if I recall, has a reputation of having some resolution difficulties… Same graphics card and driver, Manjaro KDE has no trouble with the same issue…